JUMP TO SOLUTION Solved

Original topic:

How to Turn off auto-detect HDMI

(Topic created: 07-06-2020 09:18 AM)
9022 Views
CNMark
Astronaut
Options
4K, 8K and Other TVs

How do you turn off the auto-detect HDMI feature? Sometimes my Apple TV comes on and then the TV automatically turns on as well but I don't want the TV to do so. How do you turn off this feature?

 

Thanks,

Mark

536 Replies
userrdwLp8NhPG
Asteroid
Options
4K, 8K and Other TVs
 
0 Likes
Reply
userBIHRTwtoIM
Astronaut
Options
4K, 8K and Other TVs

+1 Who wants more controll over this "auto" = "stupid" function

userCHEcglTX2R
Asteroid
Options
4K, 8K and Other TVs

Still an issue


userver2sg79Vn
Astronaut
Options
4K, 8K and Other TVs

Here in the future it still is.

0 Likes
Reply
Anonymous
Not applicable
Options
4K, 8K and Other TVs

 Yep and forever it will be.  I have been so disappointed in the Samsung products I have purchased I will not be trusting them with another purchase.  So sloppy all the time, they put on a fancy veneer and try to distract you with a million half working gimmicks with always the same half assed results.  

0 Likes
Reply
userzEmRbkEVjR
Constellation
Options
4K, 8K and Other TVs

I FIXED IT. THIS IS NOT A DRILL. 

I mean it, for real, I got it to work perfectly on my q70r, no more auto detect after I shutdown my HTPC. 

 

Background: the auto-detect function is tied to a function of hdmi called hdmi hot plug detect (Google it, it's labeled hp detect or hpd in Samsungs SW) this features is what allows TVs to detect that a new device has been plugged in, this triggers the cascade of frustration that we have all be infuriated about for 52pgs. It's a feature to allow you to quick swap hdmi connections.

 

And, AND! In the Samsung TV service menu YOU CAN DISABLE IT.

 

This being Samsungs official forum I cannot recommend or tell you how to access that menu, but I can say that Google/YouTube are magical places (hint hint) the setting in question is "HP auto detect support" , that alone should do the trick. I did change some other settings, but I advise alot of caution in this menu, I'll check back and see what other changes I made that could have impacted if but I think this setting alone did it. 

 

I've convirmed this with multiple reboots and I'm giddy right now and had to share. This issue turned my $2000 TV into what could have been a Walmart special as far as I was concerned. Bought specifically to be a HTPC TV it was basically useless. I hoped for the last year a SW update would fix this. As we all know it didn't. This does.

0 Likes
Reply
userlPPXQTOxdi
Constellation
Options
4K, 8K and Other TVs

I found the secret menu and found the entry for "HP auto detect" and switched it to "OFF" but I am still having the issue.  I have the QN65Q60RAFXZA (2020) and the Samsung HW-T650 soundbar.  I connected the soundbar via ARC (HDMI4) to the TV and every time I watch anything on the TV, it automatically switches to HDMI4 which is the soundbar.  I spoke to Samsung on the phone and they told me to do [mute + vol down + ch down + mute] on "TV" source and that didn't work.  As a work around, I am using an Optical Audio cable from the TV to the Soundbar but I find it crazy that the HDMI connection does not work as intended.  Samsung said they will call me in a few days to set up a tech visit.  I will keep you guys posted on what they find.

To be clear, I just got the TV a few months ago and I just got the soundbar just the other day.  

0 Likes
Reply
userlPPXQTOxdi
Constellation
Options
4K, 8K and Other TVs

Problem Solved!! Come to find out the issue was not with the Samsung TV or the Samsung Soundbar, the issue was with the Amazon Firecube which I had connected to the TV.  Once I removed the Firecube from the TV, the issue went away.  After further investigation and "googling" I stumbled on this reddit thread that showed me what I needed to do.   If you follow the sol'n hopefully that will work for anybody that has the same issue.

https://www.reddit.com/r/fireTV/comments/cygik2/solved_firetv_keeps_switching_tv_input_by_itself/


0 Likes
Reply
usermy1oje1ug4
Astronaut
Options
4K, 8K and Other TVs

 I managed to get into the service menu but alas 'HP auto detect support' is not there. (Samsung  Qled 55Q95T)

0 Likes
Reply
userLnjMlsusJ2
Astronaut
Options
4K, 8K and Other TVs

I was having an issue where every time I turned on my Nintendo Switch, the TV would start auto-detecting the device and trying to configure it for use with the smart remote - no matter what I did even if I was already set on the HDMI input for the Switch, it would go to the 'detecting device' screen and I'd have to use the smart remote to back out of it and then I could finally play my game. 1st world problems right? But annoying.

 

It looks like there's no 'official' way to accomplish disabling of the HDMI autodetect feature on the newer models, but someone on another thread said to try the following sequence on the remote:

 

mute, volume down, channel down, mute

 

Nothing will be displayed on the screen (in fact you'll have to unmute afterward) - and you won't even be sure it did anything. But it looks like it worked for my Samsung 8 series. Might as well be worth a try for those of you still looking to solve this. I'm not sure why Samsung reps wouldn't know about it either... odd.