Original topic:

Paramount Plus App not streaming content or live TV

(Topic created: 10-11-2022 10:02 AM)
4K, 8K and Other TVs

I am having issues streaming Paramount Plus like many other Samsung TV users. I found the solution in a post a couple of months ago. Someone gave a different DNS server setting to use other than I tried it and it worked. Paramount plus streamed perfectly. On May 3rd I called Samsung technical support and gave them the information trying to be helpful A few days ago I mistakenly reset my IP settings and lost the new DNS server setting. I did not have it written down and have not been able to find the post again. I called Samsung thinking that they would now have the information I gave them, but they did not. Very Frustrated! If anyone has seen that post and knows the DNS server setting that works with the Paramount Plus app, please let me know. Thank You! 

10 Replies
Cosmic Ray
4K, 8K and Other TVs
Back again to the issue of DNS.
I had the case opened with Paramount Plus for past few weeks for the issue not able to start streaming the movies with newest Samsung model year 2022. (B models), even after manually inputting DNS server IP address, which is NOT supposed to be the way ).
I just received email from Paramount Plus telling me the issue was fixed and resolved. And now the app worked very well with default DNS setting to automatically obtained.
I guess now the whole issue was resolved, not a Samsung TV OS issue, but it is the Paramount app issue.
If your TV app is not set to automatically updated, you should delete and reinstall the app, it should work now.
Kudos to the Paramount Plus technical support team to fix it, once for all.