JUMP TO SOLUTION Solved

Original topic:

Samsung TV Plus Not Working

(Topic created: 12-21-2020 09:03 PM)
23813 Views
userxoWT2bYogz
Astronaut
Options
4K, 8K and Other TVs

When we try to launch Samsung TV Plus we receive the following message: There was a problem while trying to play the Samsung TV Plus channel. Check your network settings or try again later. It has not worked for several days. 

 

We have unplugged the TV and plugged it back in. We have verified the network connection is good. We have reset the TV back to factory and it still does not work. 

Micob
Astronaut
Options
4K, 8K and Other TVs
l have a QN55Q6DTAFXZA TV and yesterday channel 1005 (CBSN) and 1007(ABC) stopped connecting. all other channels on TV plus work. I have tried each of the suggested solutions with no luck.
0 Likes
Reply
SamsungJam
Community Manager
Community Manager
Options
4K, 8K and Other TVs

Are you getting any errors on those particular channels?  


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.

0 Likes
Reply
Solution
user6xgwztXzyN
Constellation
Options
4K, 8K and Other TVs

We changed the DNS setting in the TV to Google's DNS (8.8.8.8) cold booted, and everything now loads. Apparently my ISP DNS was not resolving the Hulu and Samsung TV Plus addresses. Two hours with Samsung Support and they tried everything BUT this. 

 

userG2DCZVgPC5
Astronaut
Options
4K, 8K and Other TVs

Awesome, thanks!

userXdpMI1CKpG
Asteroid
Options
4K, 8K and Other TVs

I tried changing the dns with no success.  All other network apps work flawlessly.

2020 frame tv 50"

userAEXqoivu7m
Astronaut
Options
4K, 8K and Other TVs

What are the steps to the DNS settings?

0 Likes
Reply
user3FC2ZzhUw4
Asteroid
Options
4K, 8K and Other TVs
Setting up Samsung TV DNS addresses
  1. Go to Menu > Settings menu > Network > Network status.
  2. Click Network status.
  3. When the check is complete, click IP Settings.
  4. Choose the DNS setting and select Enter manually.
  5. Enter the Smart DNS location provided by yourchosen service.
userKMg4jAxoNh
Astronaut
Options
4K, 8K and Other TVs

That was weird. I tried this, didn't work. Changed it back to 'automatic' DNS settings, still didn't work. Shut the TV off and went to do more research on the computer. Came back about 5 minutes later to try something else, and it was working.

userUUI9GnQAFq
Astronaut
Options
4K, 8K and Other TVs

Thank you, changing DNS server to 8.8.8.8 worked!!!!! 

0 Likes
Reply
Micob
Astronaut
Options
4K, 8K and Other TVs
worked for me also, but stopped working after a bit.
0 Likes
Reply