Original topic:

UN50AU8000F refuses to update firmware from 1402 to 2120

(Topic created: 01-22-2023 01:37 PM)
4K, 8K and Other TVs

im having an issue with my 50 inch AU8000. the website states that 2120 is the most recent version and ive tried EVERYTHING to get it to update via OTA and by USB, nothing works. im stuck on 1420 and it keeps telling me that its the most recent. 

my 55 inch AU8000 updated recently to 2120 OTA without an issue. I spoke with Samsung live chat yesterday and they stated 2120 is indeed the most recent updated firmware, but gave no explanation why the tv refuses to update it via USB or OTA. ive already reset my tv to factory settings and reset the smart hub. when I purchased the tv two weeks ago, it did perform an OTA update during set up, I assume to 1420. is 2120 somehow being misrepresented as 1420? 2120 shows (according to the files notes of the firmware) that it was released 12-23-22.

one thing I noticed is my software version is T-NKLSAKUC and the one I downloaded from the samsung website say its T-NKLAAKUC. are these two entirely different firmwares?

the USB is properly formatted, and all the files extracted to the root folder of the USB. I tried every combination of files and folders on the USB, including all of them (folders, exe file and image files) and also just the image file alone. nothing works. 

anyone else have any ideas?




1 Reply
Community Manager
Community Manager
4K, 8K and Other TVs

Hello! That's definitely strange that you can not update the firmware. Just want to confirm you are using the files from this link correct? https://www.samsung.com/us/support/downloads/?model=N0054649


If this does not help I would recommend calling in directly at 1 (800) 726-7864 and asking for our remote management department.