Original topic:

A54 5G WiFi keeps dropping

(Topic created: 09-12-2023 02:17 PM)
7072 Views
SmartphoneUser
Constellation
Options
A Series & Other Mobile
I use WiFi most of the time and my WiFi access is WiFi 6.
WiFi 6 has been around since 2019 so it is hardly a new technology.
My A54 5G repeatedly dropped WiFi 6 connections even though all of my other phones held it stable.
I tried all of the usual remedies: Updates, Factory Resets, More Updates, different SIMs, tried another A54 5G, nada, no joy!
In most other respects the phone performed well.
I found complaints of the same problem by some other A54 5G owners. I also found an article on the internet that the very same problem with WiFi 6 was happening with the S23 series. The article was several months old and one of the other phones I have is an S23 Plus and it held its connection to WiFi 6 stable side by side with the A54 5G that was dropping WiFi 6. I tried the A54 5G back in July so I am wondering if this problem was hopefully fixed in some kind of update. I had to return the A54 5G phone, but I am willing to try it again if someone call tell me that the problem has been fixed.
 
TIA
9 Replies
Shelliam
Galaxy
Options
A Series & Other Mobile
Go to WiFi, 3 Dots at top, settings, and turn off the turn off the auto turn on/off function and the Hotspot 2.0 function. Most wifi nowadays has 2 frequencies and instead of your device just staying on 1 frequency it keeps pinging back and forth seeing which one is even the slightest bit faster. Downside to this is that the constant pinging and checking just slows wifi down even more. I'm not sure where you're located but if your more rural or fornme, when I travel down south, IA that where you ate sitting/working at home, etc. might have a weak connection. But try changing the settings in wifi and that should
Robin621k
Honored Contributor
Options
A Series & Other Mobile
Go to connections, wifi, tab the 3 dots, Intelligent Wifi,WiFi, scroll down to Intelligent Fifi 6, tap it 4 or 5 times, enabling Connectivity Labs, open Connectivity Labs, it will give you a break down of all your wifi, tell you what is the best channel to use on your routerScreenshot_20230912_200716_Settings.jpg
0 Likes
Komisari
Asteroid
Options
A Series & Other Mobile
Tried this but didn't really help
SmartphoneUser
Constellation
Options
A Series & Other Mobile

Thank you for these suggestions.

I will try to buy the A54 5G again and see if doing these suggestions fix the problems I was having.

Before I do that, I am going to see what the same settings show on the S23 Plus.

I appreciate your help.

 

0 Likes
Komisari
Asteroid
Options
A Series & Other Mobile
What did you end up doing...I really like the phone, but this is a serious issue.
0 Likes
Anahaym
Constellation
Options
A Series & Other Mobile

Have the same Problem... But does anyone know how to deactivate WiFi 2,4 Ghz? or prioritize 5 GHz over 2.4GHz? It seems that 5 GHz works better... Thanks!

0 Likes
realaud
Honored Contributor
Options
A Series & Other Mobile

@Anahaym I changed my router settings to have two different networks 2.4 & 5 ghz because most smart home devices require the 2.4 ghz network and aren't very smart about being able to choose the right frequency when the two bands are bridged. Each network has its own SSID & password, and you can connect your phone to whichever one works better for you.

0 Likes
akNick
Constellation
Options
A Series & Other Mobile
Mine keeps saying "incorrect password" same as my mom's. Got an older router and no other devices but our a54 5g phones do this.
0 Likes
userGGTpSiFuPc
Asteroid
Options
A Series & Other Mobile

I have this same problem with my A54 ever since Spectrum replaced my old router with a new router.  The new router uses WiFi 6, which wasn't available on my old router.  Never had a problem with my old router, but my phone keeps dropping WiFi all the time with the new WiFi 6 router.  This has resulting in my phone switching to my limited data plan and running up data usage without me noticing sometimes.  All other devices on my network don't seem to have this problem.  I'm trying the suggestion of turning off HotSpot 2.0 and crossing my fingers that it will work.  So far, nothing else that I have tried has worked.  My new router has very limited configuration options compared to my old one, so I can't configure channels, or control the WiFi settings much (this is also a frustration point with my new router, but I digress).  

Why doesn't Samsung provide a fix for this problem, since it is obviously an issue with the A54?

0 Likes