JUMP TO SOLUTION Solved

Original topic:

My Wi-Fi keeps turning off by itself after updating to Android 12, One UI 4.0

(Topic created: 12-02-2021 04:32 AM)
TheRev
Galaxy
Options
Android 12
Just bought an S21 Ultra, updated to Android 12, One UI 4.0.
 
My WiFi keeps turning off. Must toggle back.
 
Btw: Any suggestions as to a good wifi switching app. [To move between networks.]
 
Thanks.
8 Replies
user734264fo532
Honored Contributor
Options
Android 12
I know, crazy question ... is Airplane mode on?
0 Likes
TheRev
Galaxy
Options
Android 12
Thanks. But no... it's off.
0 Likes
PaperStation
Supernova
Options
Android 12
Perhaps look at wifi control history and see if it lists any service that is turning your wifi off. Just search for it in settings or access it it wifi settings, advanced settings
0 Likes
TheRev
Galaxy
Options
Android 12
Before trying Sy00365 suggestions, [I'm not so techy] I tried PaperStation option. WiFi Control History shows Bixby Routines. [Jetster] It actually did turn off at exactly the time I noticed this morning. I don't use Bixby in general, but have various Routines set up, including related to WiFi. [Ex: Stay Unlocked]

I guess I'll stop those Routines and see what happens.

Thanks. I love/need this Community.
0 Likes
Sy00365
Astronaut
Options
Android 12
Turn off ALL AUTOMATIONS. Then disengage the following; "Turn on WiFi Automatically" "Background usage limits", "Adaptive battery", "WiFi power saving mode" and "Power Saving". You will find these options under "WI-FI" and "DEVICE CARE" Respectively. These actions will 100% solve your issue. Once you convince yourself that it isn't turning itself off anymore, turn them on 1 by 1 and observe. Once it turns off "by itself" again, you'll know where to look, so that you can adjust the settings/automations accordingly.
0 Likes
Jetster
Comet
Options
Android 12
Basically Bixby Routines.
0 Likes
Sy00365
Astronaut
Options
Android 12
Or "IFTT", "smart things", any automation app or setting
0 Likes
Solution
TheRev
Galaxy
Options
Android 12

Hey, guys, I think I found the issue. I live in a house with cement walls. Therefore, although I have good internet, (250mbps) I use a couple of extenders. I also have a wifi switcher app to help with different networks as I move around the house. The app apparently was not configured correctly. Since I did, the S21 Ultra wifi connection does not turn off automatically.

I hope this is fixed and thank you all for your help.

Merry Christmas!

0 Likes