JUMP TO SOLUTION Solved

Original topic:

No mobile data after Android 12 update Samsung A51

(Topic created: 05-24-2022 10:02 AM)
John Dough
Cosmic Ray
Options
Android 12

After the recent Android 12 update, I no longer connect to the internet with mobile data. I need to use Wi-Fi to do anything connected to the internet.

Happened on two Tracfone Samsung A51 phones that received the update on two consecutive days , and I see other reported issues of this.

I get bars and the phone and texts work, but no connection to the internet. Mobile data is turned on, airplane mode off, data limits off and all of the other related settings check OK. Anything that I try to connect to the internet, such as a browser or Gmail, give the message "no connection".

Samsung support had me do a full reset and a safe start and I did a separate network reset. No fix. Samsung said, "take it to a service center".

1 Solution


Accepted Solutions
Solution
usergZzDYHdWDH
Astronaut
Options
Android 12

Ok, I think I have a fix.

Go to settings -> connections ->Mobile networks -> Network Operators

Turn off "select automatically"

It will search for a while.

Mine came up with a network called "home"

I clicked that, turned off wifi, and still seem to be able to surf the web... so fixed maybe?

Changed it back to "select automatically" and it still all seems to to ok.

View solution in context

36 Replies
Options
Android 12
I don't have an answer for you. Just to say that I also have an unlocked A51 5G and have not experienced the issue you mentioned here. I received the Android 12 update at the beginning of May.
0 Likes
John Dough
Cosmic Ray
Options
Android 12

Thanks,

Mine is not the 5G version.

Another weird thing it does since the update. I'll have mobile signal bars, then turn off Wi-Fi and the bars change to a circle with line and the phone status changes to "not registered on a network" and "emergency calls only." I had always had Wi-Fi calling enabled. Turning that off sometimes cured that behavior, but not always.

0 Likes
Options
Android 12
Wow, I have not experienced that either. I also use Wi-Fi calling while using Google Voice no issues there.
0 Likes
John Dough
Cosmic Ray
Options
Android 12

Both phones are Tracfones. I contacted them and they don't find anything wrong regarding mobile data not working.

I'm scouring the internet on my PC  for suggestions. Lots of results for this issue for quite some time.

I did remove the SIM card and install again as one of the suggestions. But the phone and text worked, so I didn't expect much.

When I look at the SIM card status, the "mobile network state" shows "disconnected."

I need to find anyone that knows how to change that to "connected."

0 Likes
usergZzDYHdWDH
Astronaut
Options
Android 12

Same issue with my wife's A51 after this latest update. Have also tried multiple restarts and:

  • shut down
  • remove sim
  • start up
  • shut down
  • insert sim
  • start up.

 

Still doesn't work

 

Need to fix this soon. She didn't even get my texts until she was back from a trip into town.

0 Likes
Solution
usergZzDYHdWDH
Astronaut
Options
Android 12

Ok, I think I have a fix.

Go to settings -> connections ->Mobile networks -> Network Operators

Turn off "select automatically"

It will search for a while.

Mine came up with a network called "home"

I clicked that, turned off wifi, and still seem to be able to surf the web... so fixed maybe?

Changed it back to "select automatically" and it still all seems to to ok.

John Dough
Cosmic Ray
Options
Android 12

Searched for a new network. Listed quite a few and I selected Home.

Immediately got back mobile network and the missing 4G icon next to the signal bars now shows LTE and sometimes changes to LTE+.

The SIM mobile network state now shows "connected"

Many thanks for a solution that worked for me from ZzDYHdWDH.

 

userNswMwlyOBY
Constellation
Options
Android 12

Can you list the exact steps you took to fix it? I've dealt with this issue all day and still can't figure it out.

0 Likes
usergZzDYHdWDH
Astronaut
Options
Android 12
  1. Go to settings -> connections ->Mobile networks -> Network Operators
  2. Turn off "select automatically"
  3. It will search for a while.
  4. Look for a network called "home"
  5. Click that
  6. Change it back to "select automatically"
0 Likes