cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Galaxy Watch 3 Receives All Calls?

(Topic created on: 10/29/20 7:54 PM)
Jrac86
Asteroid
Options
Discussions
Anyone else have this issue with a Galaxy watch 3? I have the galaxy watch 3 connected to my note 20 ultra. Before the beta, when I answered calls from my phone, the audio stayed on my phone. After going to the beta, every call I answer on my phone defaults to Bluetooth using the galaxy watch's speaker. I have tried rebooting both, checked all settings and do not see any option to stop this. Should only default to the watch if I answer the call from the watch.
0 Likes
7 Replies
This-is-me
Comet
Options
Discussions
are you sending error log. samsung members beta home screen
0 Likes
Jrac86
Asteroid
Options
Discussions
yes, I did the error log already, but wanted to post to see of anyone else had this issue
0 Likes
KSal
Halo
Options
Discussions
I have this same exact setup and mine is working correctly.
0 Likes
Jrac86
Asteroid
Options
Discussions
If you go to bluetooth settings and select the watch, does yours have call permissions enabled? it only does this when that permission is enabled. if it is disabled, then I can never answer calls on the watch as it just makes the phone answer the call.
0 Likes
USBetaModerator
Beta Moderator
Options
Discussions

Hello,

 

Please try steps below to see if it helps.

  1. Turn off Bluetooth
  2. Go to settings > apps > Click on arrow next "Your apps" > Select show system apps and press ok
  3. Go to Bluetooth app > storage and clear data and cache.
  4. Turn on Bluetooth

 

Please note this will remove your existing devices and may need pairing them back.

 

Regards

One UI Beta Team.

Jrac86
Asteroid
Options
Discussions
Tried this, still automatically answers to the watch.. however, doing this also didn't reset all my Bluetooth devices so I am not sure if this actually did anything.
0 Likes
Jrac86
Asteroid
Options
Discussions
Looks like the beta update fixed this issue
0 Likes