JUMP TO SOLUTION Solved

Original topic:

Galaxy Buds 2 Pro take a minute to connect for calls on S22 Ultra

(Topic created: 08-03-2023 10:48 AM)
2525 Views
brentthemac
Asteroid
Options
Galaxy Buds

I've had my Buds 2 Pro serviced multiple times now for the same issue, and it hasn't been resolved.  When I put them in, they connect immediately for audio, but it takes about 45 to 60 seconds before it will recognize them for calls.  If I go into the bluetooth menu, the call slider is toggled off, and will not allow me to toggle it to be active.  After about a minute, the toggle will automatically turn on, and pause any audio that was playing.

When I initially purchased them, this was not an issue.  I sent them in for repair of faulty ANC, and when I received the replacements, and subsequent replacements, this was an issue.

I ran the diagnostics on the buds' microphone as soon as inserting them, and they are able to record through the mics immediately after inserting them.  Just not able to be used for calls.

I've reset, and am on the latest updates for both the S22 Ultra and the Buds.

Any help would be appreciated!

0 Likes

1 Solution


Accepted Solutions
Solution
brentthemac
Asteroid
Options
Galaxy Buds

So I tried connecting them for the call, then unpairing them, and reenabling the watch to take calls, and now the issue seems to be resolved for now!  Not sure why it worked, or for how long, but at least I have had some success!

Thank you for your help!

View solution in context

0 Likes
11 Replies
VerbumVeritum
Legendary Samsung Care Ambassador
Options
Galaxy Buds

@brentthemac  You mentioned you already tried resetting the Buds through the Galaxy Wearable app, correct? Go ahead and try a few times in a row. Sometimes it "just works" for some reason.

You could also try putting your phone into Safe Mode to test if a 3rd party app is causing the issue. This can be done by bringing up the power menu and then pressing + holding power off until you see the Safe Mode option. If the Buds work, then some sort of 3rd party app is causing conflicts. 

If the problem still persists with the phone in safe mode, the next step would be to restart the device normally and then head to Settings>General management>Reset>Reset network settings to clear your network connection settings (you will have to setup prior WiFi & Bluetooth connections again). 

brentthemac
Asteroid
Options
Galaxy Buds

Thank you for your response!

When I tried safe mode, it did seem to detect it for calls.

If it is a third party app, are there any steps to determine which may be overriding the call function?

Thank you again!

VerbumVeritum
Legendary Samsung Care Ambassador
Options
Galaxy Buds

@brentthemac There is a way to narrow down the list. You can check your permissions in Settings>Security and privacy>Privacy>Permissions manager to see which apps have access to phone, microphone, etc. 

brentthemac
Asteroid
Options
Galaxy Buds

Thank you! Only three apps accessed the mic permission in the last 24 hours. Denying the permission to them had no effect.

When I look at the Bluetooth screen, it shows the call toggle on for a few seconds, then it turns off, and won't re-enable for another 45 seconds.

Would you have any suggestions as to which apps might need to be disabled? Would it include apps that have to ask permission for each use?

Thank you so much!

0 Likes
VerbumVeritum
Legendary Samsung Care Ambassador
Options
Galaxy Buds

@brentthemac To be honest, I'm not sure. It could be.

Are there any other apps that access Bluetooth or calling that you use? I kind of doubt that clearing your network settings would help, but there is always that option. 

brentthemac
Asteroid
Options
Galaxy Buds

I tried clearing the network settings just in case, but it didn't resolve it.

There are 32 apps with phone permissions, but the only ones accessed in the past 24 hours are Phone, WhatsApp, and Galaxy Watch5 Manager.

I did try disabling calling on the Galaxy Watch5 and my initial tests seem to indicate that it is fixed from that.  However, I often do use the watch for taking calls, so that isn't a great long term solution.  Are there any workarounds for allowing the watch to receive calls at the same time as the buds?

Thanks very much for your help!

0 Likes
VerbumVeritum
Legendary Samsung Care Ambassador
Options
Galaxy Buds

@brentthemac That just made me think.... if you connect your Buds to your watch's Bluetooth, do you still have the same delay with making calls? 

0 Likes
brentthemac
Asteroid
Options
Galaxy Buds

They appear to show the call toggle enabled immediately when I connect to the watch.  Interesting...

0 Likes
VerbumVeritum
Legendary Samsung Care Ambassador
Options
Galaxy Buds

@brentthemac So that basically confirms that your phone is the issue, and some sort of conflict (maybe related to the watch and its manager app) is causing it for some reason. You can try going through the process of clearing the cache of the Galaxy Wearables app and it's accompanying manager application (Galaxy Watch5 manager). You could also try uninstalling and reinstalling Galaxy Wearables altogether. 

0 Likes