JUMP TO SOLUTION Solved

Original topic:

Z Fold 5 wifi taking 15-30 seconds to connect

(Topic created: 01-06-2024 09:21 AM)
600 Views
userc5LNFOc0Mn
Asteroid
Options
Galaxy Fold

Z Fold 5 wifi taking 15-30 seconds to connect  when I go to any app.  When I hold down on wifi icon it shows it trying to connect to my wifi then finally connecting. 

0 Likes
Reply

1 Solution


Accepted Solutions
Solution
userc5LNFOc0Mn
Asteroid
Options
Galaxy Fold

I did power cycle the router.

I did boot to safe mode, but the problem persisted.

"When you say "Reset wifi settings" do you mean you reset the network settings  at Settings->General Management->reset->Reset Network Settings?"

My Z Fold 5 SAYS:  >General Management->reset->Reset Wi-FI and Bluetooth. and there is a 'Reset mobile network setting' 

When on my mobile network, the phone connects immediately with no delay.

Thanks for your suggestions

Found possible solution:

When I clicked on reset 'Wi-Fi and Bluetooth', there was no option to not also reset Bluetooth. So, I had to set up my Galaxy Watch 5 Pro again. It took several attempts until I realized that I had to reset the watch before it would set up.

After successfully setting up the watch, I realized the phone was once again connecting to Wi-Fi with no delay. 

 

 

 

View solution in context

0 Likes
Reply
6 Replies
Options
Galaxy Fold
How's the signal? Do other devices in your home connect instantly?
0 Likes
Reply
userc5LNFOc0Mn
Asteroid
Options
Galaxy Fold

The Wi-Fi signal is strong, and all other devices in the home connect instantly.

Restarted phone, reset wifi settings, turned off any battery savings when using wifi in developer mode, restarted phone again.

When the delay occurs, pressing on the wifi icon, I get a window that shows my wifi is on, says my current network is connected with a strong signal, and below that it says "Turning on...".

After 15-30 seconds, it turns on, and then everything for that site is fine.

With wifi off using 5G everything loads up immediately.

 

0 Likes
Reply
Options
Galaxy Fold
• Do you have any third-party anti-virus apps on your phone?
• Do you have auto-connect turned on?
• Do you have more than one wifi network available under the same router?
0 Likes
Reply
userc5LNFOc0Mn
Asteroid
Options
Galaxy Fold

"Do you have any third-party anti-virus apps on your phone?"  NO
• "Do you have auto-connect turned on?" YES
• "Do you have more than one wifi network available under the same router?" NO

Thanks for your suggestions

0 Likes
Reply
bill-e
Epic Samsung Care Ambassador
Options
Galaxy Fold

When you say "Reset wifi settings" do you mean you reset the network settings  at Settings->General Management->reset->Reset Network Settings? 

Power cycle the router... yea I know everything else is working but this is to reset the router for your Fold's connection. 

Boot to Safe Mode and see if the problem persists. 

** If my response helps, please click on Like (Heart). If I resolved your issue also please click on Accept as a Solution so that others can benefit.

Bill
---
Galaxy Fold 5 512g(VZW), Galaxy Book (original, VZW), Tab S8 Ultra, Tab S4, Galaxy Watch6Classic 47mm(VZW), Galaxy Watch5Pro(VZW), M8 Smart Monitor
0 Likes
Reply
Solution
userc5LNFOc0Mn
Asteroid
Options
Galaxy Fold

I did power cycle the router.

I did boot to safe mode, but the problem persisted.

"When you say "Reset wifi settings" do you mean you reset the network settings  at Settings->General Management->reset->Reset Network Settings?"

My Z Fold 5 SAYS:  >General Management->reset->Reset Wi-FI and Bluetooth. and there is a 'Reset mobile network setting' 

When on my mobile network, the phone connects immediately with no delay.

Thanks for your suggestions

Found possible solution:

When I clicked on reset 'Wi-Fi and Bluetooth', there was no option to not also reset Bluetooth. So, I had to set up my Galaxy Watch 5 Pro again. It took several attempts until I realized that I had to reset the watch before it would set up.

After successfully setting up the watch, I realized the phone was once again connecting to Wi-Fi with no delay. 

 

 

 

0 Likes
Reply