Issue with switching between wifi and mobile data

Highlighted
Asteroid

Issue with switching between wifi and mobile data

I am having an issue with mobile data kicking in automatically when I leave a wifi area. Anyone else having this issue?
11 REPLIES
Asteroid

Re: Issue with switching between wifi and mobile data

Maybe I'm not inderstanding your question but isn't that whats supposed to happen?  When you leave wi-fi your moble data should take over.

Asteroid

Re: Issue with switching between wifi and mobile data

It should take over, but it doesn't. I have to spend at least 5 minutes to get mobile data to work after leaving a wifi spot.
Nebula

Issue with switching between wifi and mobile data

ok..what carrier do you have, and are you still aving the issue?
Astronaut

Issue with switching between wifi and mobile data

I'm going through the same exact problem currently.. I have wifi at home but mobile data goes out while I am here.. I have boost mobile and use a Samsung galaxy J3 from 2016
Asteroid

Re: Issue with switching between wifi and mobile data

I also have a similar issue with my mobile data connection. When I leave my WiFi area, my phone does not automatically connect to my mobile data connection, which I always leave it on. Then I will not be able to use any app that require data connection. I usually have to manually turn on the flight mode and turn it off, and only after that the mobile data will connect.

Re: Issue with switching between wifi and mobile data

[ Edited ]

@usercpqAXptoFk @user3jj5qFeHxD @Brent9201 does anyone have Smart Network Switch enabled in their Wi-Fi Advanced Settings? This may fix this issue

Asteroid

Re: Issue with switching between wifi and mobile data

I do have that turned on on my note fan edition,, btw it's call adaptive Wi-Fi in its settings, but it doesn't seem working. Everytime I came out of my Wi-Fi zone (home) it'll drop the Wi-Fi, of course, and wouldn't connect to mobile data. At first I'll restart my phone and that fixes it. Later on I tried with switching on and off of flight mode also does the trick. So in order to catch the mobile data signal, I'll have to manually turn on the airplane mode and off.

Re: Issue with switching between wifi and mobile data

@usercpqAXptoFk if the Smart Network Switch isn't working, the only other option I know of is to

go to Settings-Developer Options- enable Keep Mobile data turned out

 

Asteroid

Re: Issue with switching between wifi and mobile data

Alright, I'll try to turn it on and take note of the Wi-Fi and data connection. I'll feedback again tomorrow.