JUMP TO SOLUTION Solved

Original topic:

Note10+ Keyboard not working when using Dex on Mac0S X

(Topic created: 03-04-2020 07:38 PM)
CanAnhTung
Asteroid
Options
Galaxy Note Phones

Hi there,

 

Did anyone get a physical keyboard issue when using Dex on MacOS X?

 

I've connected my Note10+ to Macbook air, the trackpad works perfectly but the MacBook keyboard does not work. I've noticed that when trying to type something, the on-screen keyboard has popped up on the Note10+. 

 

Is there anyone who know how to deal or fix it?

 

Best regards,

Tung

 

JUMP TO SOLUTION
SERichards
Constellation
Options
Galaxy Note Phones

I'm using an iMac, just tried connecting my Note 10+ to use DEX for the first time. My keyboard didn't work. I'm using an Apple keyboard Bluetooth. 

 

I discovered I had to enable Samsung DEX and AEServer in the Security & Privacy>Accessibility tab. That worked finally. I think the AEServer was recently added with the latest MacOS update. 

 

Hope that helps!! 

 

Steve

Samsung_R6Eppad
Astronaut
Options
Galaxy Note Phones

This worked for me like charm. I would suggest other people who is facing this problem try this just give permission to samsung dex that's it... Thank you so muh sir...

userhToWenhjOp
Astronaut
Options
Galaxy Note Phones

Wow, that worked for my. Enabling AEServer was the key. I had previously tried all other methods. Had even enabled DEX on Security & Privacy but bot AEServer. 

 

Thanks!

0 Likes
Reply
userZ5RPijUDqp
Astronaut
Options
Galaxy Note Phones

This is the exactlly solution. 

usertociiAhDbI
Astronaut
Options
Galaxy Note Phones

This worked for me! I had to restart the Mac after enabling accessibility for DEX and AEServer. Thank you!

usercFQmEZ05E0
Constellation
Options
Galaxy Note Phones

Hey the Samsung marked solution is in fact not a solution - this is. Hats off to SERichards for figuring out that AEServer as well as DeX both need accessability permission set. As usertociiAhDbl pointed out you must restart the DeX App on the host computer.

0 Likes
Reply
DSmeth
Astronaut
Options
Galaxy Note Phones

This didn't work for me. A suggestion from another user on this thread did so read on.

userGn0fIQu8j1
Astronaut
Options
Galaxy Note Phones
does not work for me either
0 Likes
Reply
userLKT8FTJndU
Constellation
Options
Galaxy Note Phones

In my case, this solution did not work.

 

In my case, what worked was adding the dex application in the accessibility settings.

 

To do that, just go to:

System Preferences on the mac > Security & Privacy > Choose on the Left Accessibility, click in the little locker in the bottom left corner.

 

Check the box of the DEX application. Restart Dex and it should work. Good luck.

0 Likes
Reply
useri7F25T4sOj
Constellation
Options
Galaxy Note Phones

Hi

 

personally I resolved the problem uninstalling a keyboard extensions on my mac , karabiner-elements.

 

After that no more problems.

 

Currently I'm using :

@Home DEX on a macbook pro 2018, macos Mojave 10.14.6 and a keychron bluetooth keyboard (connected to my mac when at home)

@onthego  DEX on my NOTE10 the same BT keyboard and a MS BT mouse 

 

Thanks

 

 

 

0 Likes
Reply