cancel
Showing results for 
Search instead for 
Did you mean: 

Bluetooth turns off when Airplane mode turned OFF, Galaxy S7 Nougat

JUMP TO SOLUTION

Since the Nougat update I've had a change in behavior when it comes to Bluetooth and airplane mode.

 

On Marshmallow, the state of bluetooth was not modified when turning on airplane mode. Now whenever I toggle airplane mode (either turning it on or turning it off) my bluetooth turns off. Is this the expected behavior? I preferred the old behavior, as I have a Gear S2 watch and want it to always be connected. My first two days with Nougat caused very high battery drain in the watch because I didn't realize that turning Airplane mode OFF would also turn Bluetooth OFF.

 

At least I can understand turning bluetooth off when Airplane mode is turned on, but why would it ever be turned off when turning airplane mode off? For now I'm using Tasker to solve the issue, but I feel like this is a bug that shouldn't be happening.

1 SOLUTION

Accepted Solutions

Re: Bluetooth turns off when Airplane mode turned OFF, Galaxy S7 Nougat

JUMP TO SOLUTION

Thank you, I posted my question there.

 

In the mean time, though, for anybody else who is curious, I was able to solve the problem and essentially modify my airplane mode button to only disable the cell radio, wimax, and NFC while leaving WiFi and Bluetooth on.

 

I removed wifi and bluetooth from the airplane_mode_radios variable using ADB and now I have the behavior I want, even if it's not the "correct" behavior. This also seems to have fixed the problem of bluetooth turning OFF when airplane mode is turned OFF, so I'm happy.

 

The reason I care about this is because my office is in the middle of the building and I have no cell service, so in order to prevent battery death I have to turn airplane mode on every day when I get to work and then turn it off when I leave, and I really only want the airplane mode button to function as a "cell radio off" button, which it now does. If I need to fly, which is rare, I can turn all of the radios off manually.

 

http://android.stackexchange.com/questions/59664/possible-to-turn-on-airplane-mode-with-wifi-on-only

Reply
Loading...
5 REPLIES 5

Re: Bluetooth turns off when Airplane mode turned OFF, Galaxy S7 Nougat

JUMP TO SOLUTION

UPDATE: I cleared my cache partition and this odd behavior seems to have stopped. I will update again if anything changes again.

 

UPDATE 2: After a few tests, the behavior has returned. When I first rebooted after clearing the cache, I turned off airplane mode and bluetooth stayed on. I then did it again, and bluetooth started turning off when airplane mode was turned off. This is NOT the expected behavior, and why is it not behaving consistently?

Reply
Loading...

Re: Bluetooth turns off when Airplane mode turned OFF, Galaxy S7 Nougat

JUMP TO SOLUTION

UPDATE 3: It seems a simple restart "fixes" the issue once, and then it returns after toggling airplane mode a second time.

Reply
Loading...
Honored Contributor

Re: Bluetooth turns off when Airplane mode turned OFF, Galaxy S7 Nougat

JUMP TO SOLUTION

I'll have to test this specifically on one of the Nougat devices we have here at the office. We have an announcement thread that we've been centralizing all this information to. If you haven't had time to check it out, here's the link - [Announcement] Nougat 7.0 Update Problems *UPDATED 03/08*

 

Feel free to update their with your findings as well as who your current carrier is.


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you. If a post stand out to you, perhaps you could give that post a star to show other community members they were able to assist or was relevant to you.

Reply
Loading...

Re: Bluetooth turns off when Airplane mode turned OFF, Galaxy S7 Nougat

JUMP TO SOLUTION

Thank you, I posted my question there.

 

In the mean time, though, for anybody else who is curious, I was able to solve the problem and essentially modify my airplane mode button to only disable the cell radio, wimax, and NFC while leaving WiFi and Bluetooth on.

 

I removed wifi and bluetooth from the airplane_mode_radios variable using ADB and now I have the behavior I want, even if it's not the "correct" behavior. This also seems to have fixed the problem of bluetooth turning OFF when airplane mode is turned OFF, so I'm happy.

 

The reason I care about this is because my office is in the middle of the building and I have no cell service, so in order to prevent battery death I have to turn airplane mode on every day when I get to work and then turn it off when I leave, and I really only want the airplane mode button to function as a "cell radio off" button, which it now does. If I need to fly, which is rare, I can turn all of the radios off manually.

 

http://android.stackexchange.com/questions/59664/possible-to-turn-on-airplane-mode-with-wifi-on-only

Reply
Loading...
fingertrick
Constellation

Re: Bluetooth turns off when Airplane mode turned OFF, Galaxy S7 Nougat

JUMP TO SOLUTION

@SamsungMarcos wrote:

I'll have to test this specifically on one of the Nougat devices we have here at the office. We have an announcement thread that we've been centralizing all this information to. If you haven't had time to check it out, here's the link - [Announcement] Nougat 7.0 Update Problems *UPDATED 03/08*

 

Remove the post if you can't supply nothing but dead links

Feel free to update their with your findings as well as who your current carrier is.


Reply
Loading...