Original topic:

Can't call or text on Galaxy S9+

(Topic created: 06-13-2022 10:03 AM)
user6Yvq08lD9V
Asteroid
Options
Galaxy S Phones

Since Thursday I haven't been able to make or receive calls or receive texts. I called my carrier, PureTalk (Uses AT&T towers) 3 times. The first two times they told me my phone wasn't compatible with 4G or 5G and since the 3G shutdown my phone wouldn't work anymore. My third time I finally talked to someone who acknowledged my phone is 4G compatible, we reset the APN which got my mobile data working (off and on) and I can send texts but not receive them, still can't make or receive calls. She gave me a service ticket # I can call and follow up on but since they seem stumped I wanted to come here to see if anyone had any suggestions? Help much appreciated!

12 Replies
Patriot1776JG
Supernova
Options
Galaxy S Phones
Many ideas
1. Remove the SIM card
2. Turn on Airplane mode, for 10 seconds, then turn off
3. Manually reset your phone
4. Completely turn phone off, on
5. Network reset
From setting > General Management > Reset > Reset Network Settings
FYI: Doing this will clear any WIFI, & Bluetooth setting, and afterwards you will need to re-install
6. Hope one of these suggestions help you
0 Likes
user6Yvq08lD9V
Asteroid
Options
Galaxy S Phones

Unfortunately I have already tried all these, but thanks for the suggestions.

Elupita
Astronaut
Options
Galaxy S Phones
The same thing happened to me and they tried everything, I even got to the point of changing my cell phone number on the recommendation of my provider (att) I had 3 weeks without service until finally they only told me that it was no longer compatible with the 5G network, which good thing is that I took advantage of the exchange promotion and I received an s22 for only $65, the only thing I can tell you is to change your phone and end your nightmare, good luck!!!
0 Likes
user6Yvq08lD9V
Asteroid
Options
Galaxy S Phones

No sure if this is relevant but under Network Mode I have LTE/3G/2G (auto connect) selected. The other options are:

3G/2G (auto connect)

3G only

2G only

 

Should there be another option? I'm wondering if Samsung or someone needs to send a software update.

0 Likes
Jamess467
Red Giant
Options
Galaxy S Phones
How bout this: setting/connection/mobile network/connection type.
If it is global, tap it and change it to cdma
0 Likes
user6Yvq08lD9V
Asteroid
Options
Galaxy S Phones

I'm not seeing a connection type option under Mobile Networks?

0 Likes
Sarge2
Cosmic Ray
Options
Galaxy S Phones
AT&T is only a GSM network and changing to CDMA will make the phone not work on an AT&T network.
Verizon is a CDMA network.
0 Likes
Jamess467
Red Giant
Options
Galaxy S Phones
You can change it to GSM in the same menu.
0 Likes
Charkatak
Black Hole
Options
Galaxy S Phones
Have you tried selecting a next one down from your current selection under network mode?

0 Likes