JUMP TO SOLUTION Solved

Original topic:

Dex doesn't work with Windows 10

(Topic created: 11-06-2019 12:22 PM)
Mtiede
Comet
Options
Galaxy S Phones

I watched a YouTube video that showed using Dex with Windows 10 and I thought, "I want to do that!"

 

So I downloaded the Windows 10 Dex app and installed it.  All seemed to go well.  Then it wanted me to plug it into the USB port of the computer, which I did.  But the App just sits there waiting to see the phone being plugged into the computer.  It has red exclamation points on the USB connectors in the diagram.

 

But Windows tells me that the device was plugged in.  And I can see it in File Manager.  And transfer files between the two using File Manager.

 

I tried rebooting phone, uninstalling and re-installing the Windows 10 app, uninstalling, deleting and re-installilng USB drivers, re-installing .  Still nothing.

 

I looked into Device Manager and I see two USB drivers associated with Samsung.

 

"Samsung Mobile USB Composite Device" and

"Samsung Mobile USB Connectivity Device V2"

 

The phone has a notification that says "You can use Dex on your computer".  At one point, a dialog on the phone popped up and I could see that "Transferring files" option was set for USB.

 

What am I missing?

 

LongHiker
Epic Samsung Care Ambassador
Options
Galaxy S Phones

@Mtiede wrote:
no, it was released back when I posted. as I said back then, once the drivers were updated, it worked fine.

The drivers may have been available for the PC but not for the S10. 

0 Likes
Reply
Mtiede
Comet
Options
Galaxy S Phones
forget it
0 Likes
Reply
Mtiede
Comet
Options
Galaxy S Phones

Hmm...  I don't think I'm using UI 2.0 beta2.  How do I clear the phone's cache partition?  I've read a couple of posts and it is confusing me 🙂

 

And I hope it isn't going to lose ANY files I have, correct?

 

Are you in the U.S. since someone it worked for other countries, but not the U.S.?

0 Likes
Reply
Mtiede
Comet
Options
Galaxy S Phones

Do you ALSO run "Your Phone" app on the PC?  I'm wondering if there is a conflict with that and Dex as they sort of do similar stuff.  I can see the phone screen and interact with the phone from within "Your Phone" through the USB.  So, inquiring minds want to know...

 

I tried to uninstall the "Your Phone", but uninstall was grayed out.  I DID do a "Terminate" hoping to stop all the things it uses, but it didn't help.

0 Likes
Reply
userF3JunaVH2l
Astronaut
Options
Galaxy S Phones

Thanks, I've tried everything here, the only one that worked was clearing the phone's cache.

0 Likes
Reply
sultann
Astronaut
Options
Galaxy S Phones

Clearing the cache partition on my S10 worked for me after nothing else did.  However, it's not clear how to do this.  I have Verizon, but their help article on clearing the cache wasn't helpful.  I found detailed instructions on TMobile's site, and clearing the "cache partition" worked for me (after following the above instructions for installing the USB device drivers AND installing the Wireless Display option in Windows 10 - https://www.tenforums.com/tutorials/157692-install-uninstall-connect-wireless-display-feature-window... 😞 https://www.t-mobile.com/support/devices/android/samsung-galaxy-s10/wipe-cache-partition-samsung-gal...

0 Likes
Reply
Solution
Mtiede
Comet
Options
Galaxy S Phones

Yay, I got it.

 

I went to this web page:

 

https://help.content.samsung.com/csweb/faq/searchFaq.do 

 

 

And found these instructions:

 

Disconnect and then reconnect your USB cable while Samsung DeX for PC is running on your PC.

Once your mobile device is recognized by your PC, a "Samsung DeX is connected." message will appear in the notification panel on the mobile device, and then the Samsung DeX Home screen will appear on the PC screen.
If you can't see the Samsung DeX Home screen even after reconnecting the USB cable, try the following:

- Reinstall the USB Driver on your PC.
▷ USB Driver installation directory on a Windows PC: C:\ > Program Files (additional characters, such as "(x86)", may follow depending on the system) > Samsung > Samsung DeX > USB Driver > SAMSUNG_USB_Driver_for_Mobile_Phones.exe
※ A USB driver for Mac is not provided separately.

- The driver may not run immediately after installation. In that case, restart your PC.
- If the USB cable or hub is damaged, you may not be able to connect. Try a different USB cable or hub.
※ If Samsung DeX does not work correctly on a PC running on Qualcomm's Snapdragon platform (Windows on ARM), we recommend that you connect the PC through a USB hub instead of connecting it directly using a USB cable.
- Check the USB option through the notification displayed on your device. Then, select "This phone" for the "USB controlled by" option.
- Check whether the "Samsung DeX" icon is on the system tray of the taskbar. If you don't see it, run the "Samsung DeX" program. If you see the "Samsung DeX" icon, reconnect the USB hub or cable.

※ PCs within a company and public PCs typically have their own security software installed, so you may be unable to connect to them via USB. If you can't connect to a PC via USB, contact the administrator of the relevant PC

 

 

 

I ran the SAMSUNG_USB_Driver_for_Mobile_Phones.exe and re-installed the drivers.  That didn't help, but I rebooted the PC and then I think it took.  When I next plugged in the phone, the app auto launched and the red exclamation points were now spinning circles and then it connected.

 

Cool.

 

And...  I just realized Dex recognizes my touch screen gestures too.  Very nice.

userIOPGdGM4Yj
Constellation
Options
Galaxy S Phones

Dex was working properly on my Windows 10 laptop for about a week then after installing Windows updates the Dex app on my laptop stopped recognizing my S10e.  The file transfer pops up, so I know the laptop is seeing the phone.  I removed all the updates that I was able to from the day Dex stopped working, but it didn't work.  Also every time I restart my laptop Dex asks me to install the Samsung driver.  I'll install it time and time again, from different sources, but it doesn't work.  HELP!! I loved using the app and desperately want it back.  

0 Likes
Reply
userF3JunaVH2l
Astronaut
Options
Galaxy S Phones

I had the same problem with my note 9, the only thing that worked for me was clearing the phone's cache.

0 Likes
Reply
userHeIDFIRTw6
Astronaut
Options
Galaxy S Phones

1. Click on search or start buttn on task bar of windows

2. Type "Add an optional feature" and select it.

3.  Click on "Add a feature"

4. Search for "Wireless Display" and install

5. Restart your computer and try dex again.

 

Even if you are using wired dex with PC, you need this to be installed. After latest windows update this got removed automatically. So, need to add it again.