JUMP TO SOLUTION Solved

Original topic:

Display > Screen Timeout setting won't stick

(Topic created: 12-14-2020 01:55 PM)
RFisher10
Asteroid
Options
Galaxy S Phones

I keep setting the Display > Screen Timeout setting to 2 minutes, but it keeps reverting to 15 seconds. Is some other app is changing this setting? How do I figure out what is causing this.

 

Thank you.

1 Solution


Accepted Solutions
Solution
RFisher10
Asteroid
Options
Galaxy S Phones

I think I have figured out the problem. As I mentioned, I'd go through days where there was no problem, and then seemingly out of the blue, the setting changed to the 15 seconds. Today, the setting changed and the only app I had used prior to that was my Sound Profile app. This is an app that allows me to quickly select "Silent" so it turns off all my sounds (when I am in movie theater, at a meeting, etc). I looked a bit deeper into this app and it turns out that when you select "Silent", it changes the display timeout to 15 seconds!! It did't occur to me that an app for controlling audio would also change a display setting!

 

Thank you to all who helped me troubleshoot this problem. I learned a lot in the process!

View solution in context

0 Likes
Reply
15 Replies
SHADOWGATE
Supernova
Options
Galaxy S Phones
is there any of your power savings options turned on? they would overwrite your settings. Also I recommend ditching the manual screen timeout settings and using your "Smart Stay" feature. It utilizes your camera and checks to see if your face is in front of it and keeps your screen on for you. Might be more useful
0 Likes
Reply
RFisher10
Asteroid
Options
Galaxy S Phones

I looked under Settings > Device Care > Battery and noted that Power Mode is set to Optimized. I couldn't see anywhere to check what that means--that is, does this have settings for various apps/time outs, etc?

0 Likes
Reply
SHADOWGATE
Supernova
Options
Galaxy S Phones
yeah Battery optimization turned on will keep your screen at idle more to save power
0 Likes
Reply
CLF
Samsung Care Ambassador
Options
Galaxy S Phones

Hey, 

@RFisher10

If you haven't already checked this open device care, select the settings menu icon at the top right corner. Once the menu opens select advanced. At the bottom of the menu you should see an item titled optomize settings. Tap the left side of it and a new menu will open with options to reduce brightness, screen timeout, and media volume. It automatically resets the screen timeout to 30 seconds. I turned optomize settings off. 

I have power mode set to optimized and the screen resolution set to WQHD+. I remove some apps from the optomize list manually because it can effect their capabilities, Gmail, Nova, KLWP, PowerAmp, third party messages apps ect. 

Best regards, 

CLF 

 

0 Likes
Reply
RFisher10
Asteroid
Options
Galaxy S Phones

I found the page described (Device Care > Advanced >  Optimize Settings): I already have Screen timeout set to 2 minutes. So I try again and select Optimize Settings and notice the 2 minute radio button selected.  But then when I return to the previous page, Screen timeout still says "Screen will turn off after 30 seconds of inactivity".

0 Likes
Reply
CLF
Samsung Care Ambassador
Options
Galaxy S Phones

Hey, 

You've turned off optomize settings completely. Restarted the device and set the screen timeout to two minutes and set the screen to lock a few minutes later.

If it's still resetting back to 30 seconds I'm not sure what to try next.

I wipe the system cache partition once in a while which clears up some minor issues.

Safe Mode does rule out third party apps that might be interfering with the screen timeout. I'll look around and see if anyone found a different solution for this.

Best regards, 

CLFScreenshot_20201215-072448_Device care.jpg

 

0 Likes
Reply
SHADOWGATE
Supernova
Options
Galaxy S Phones
Have you made any changes to the Screen brightness. Just a thought but if the brightness is set higher then the optimal it might be causing the Battery Optimization settings to kick in and supplement the screen by limiting the amount of time it stays on. More than likely its gonna be something simple like that.
0 Likes
Reply
RFisher10
Asteroid
Options
Galaxy S Phones

What changes to Screen brightness do you mean? Is there a default level?

 

The time-out at 2 minutes stuck for a few days but then today, it went back to 15 seconds. I've experimented with setting it at 2 minutes and then restarting to see if that changed it to 15 seconds: answer No.

 

Device care > Advanced:

Auto Optimization Off
Auto restart: Off
Optimize Settings: Off

Display > Adaptive brightness: Off

 

SHADOWGATE
Supernova
Options
Galaxy S Phones
Settings>Applications>3line(top right)> Special Access > Battery Optimization and see if there are any orders the Device itself is Overriding on it's own. This section will give you Manual Device Authority

clipboard_image_1609369892511.jpg

clipboard_image_1609369975492.jpg

0 Likes
Reply