JUMP TO SOLUTION Solved

Original topic:

GMail notifications not working

(Topic created on: 1/12/20 1:35 PM)
Options
Galaxy S Phones

Ever since I received the android 10 update last month I noticed that under Accounts, under Goggle, my gmail doesn't sync like it used to, it gets stuck. I still get the e-mails but I don't get the notifications I have to manually sync it. I've already done safe mode, nothing. I am not doing a factory reset nor am I removing the account then putting it back, the last time I did that it was a nightmare... does anybody else have any suggestions.

0 Likes
Reply
12 Replies
Options
Galaxy S Phones

Forgot to add when the phone is charging or when it is open and I'm checking other apps I get the notifications it's only when the phone is off that this happens.

0 Likes
Reply
Solution
jgheitman
Asteroid
Options
Galaxy S Phones

I have a similar issue. If I open gmail and manually refresh the emails come through. I had this issue with android 9 but when I took gmail off the list of battery optimized apps it removed the issue. With the android 10 update, it's back. I have a galaxy s9 for my work phone and that receives emails on gmail instantly, so I'm pretty sure it's tied to android 10 update...

View solution in context

0 Likes
Reply
SamsungQue
Samsung Moderator
Samsung Moderator
Options
Galaxy S Phones

@jgheitman Did you try clearing the cache for your gmail app?

0 Likes
Reply
carl0524
Constellation
Options
Galaxy S Phones

Is this happening to anyone who owns the Samsung 20?  I went from the S10e to the 20 hoping the problem would be gone. I had the S10e for four weeks talking to tech support at tmobile and samsung without any luck.  Now its doing it on the 20.

0 Likes
Reply
Samsung_rSv0vao
Astronaut
Options
Galaxy S Phones

Yup

0 Likes
Reply
jgheitman
Asteroid
Options
Galaxy S Phones

Not sure how but how come I never had to before? Why is it not an issue on my Galaxy S9?

0 Likes
Reply
SamsungQue
Samsung Moderator
Samsung Moderator
Options
Galaxy S Phones

@jgheitman Here are the steps to place your phone into safe mode. 

  1. Press and hold the Power button until the 'Power off' prompt appears on the screen then release.
  2. Touch and hold Power off until the 'Safe mode' prompt appears then release.
  3. To confirm, tap Safe mode.
    Note The process may take up to 30 seconds to complete.
    Note Upon reboot, 'Safe mode' appears in the lower-left of the unlock / Home screen.
  4. With Safe Mode enabled, test device and app functionality.
0 Likes
Reply
SamsungZell
Samsung Moderator
Samsung Moderator
Options
Galaxy S Phones

You are very welcome. Keep us posted, if the symptom returns.


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.





Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

0 Likes
Reply
Options
Galaxy S Phones

I just took Gmail off the list of battery optimized apps hopefully that helps, I also cleared the partition as well. Thanks for all the information appreciate it.

0 Likes
Reply