JUMP TO SOLUTION Solved

Original topic:

GMail notifications not working

(Topic created on: 1/7/20 6:42 AM)
Options
Galaxy S Phones

Ever since I received the android 10 update last month I noticed that under Accounts, under Goggle, my gmail doesn't sync like it used to, it gets stuck. I still get the e-mails but I don't get the notifications I have to manually sync it. I've already done safe mode, nothing. I am not doing a factory reset nor am I removing the account then putting it back, the last time I did that it was a nightmare... does anybody else have any suggestions.

0 Likes
Reply
JUMP TO SOLUTION
12 Replies
userJBvBCaJ3Tt
Astronaut
Options
Galaxy S Phones

I have fixed this. I know this thread is 6 months old but I haven't been able to find a solution and it didn't seem to be posted here so I thought I'd add this.

 

I haven't had notifications for a long time. I tried high-performance setting in battery. Adding Gmail to apps that never go to sleep in Apps. Nothing worked. 

What did work was disabling the gmail app - click and hold the icon then select disable. Then re-enabling it in settings > apps and choosing disabled from the drop down list then click Enable. Works perfectly now.

Hope it helps someone!

user2grnA96tVn
Astronaut
Options
Galaxy S Phones

It did help thank you so much!! I had tried all the solutions suggested in many articles but nothing worked, so thank you very much!!!! 

0 Likes
Reply
userhB08SnOQ8C
Astronaut
Options
Galaxy S Phones

Over the weekend, my S9 stopped giving me gmail notifications.  My gmail account will sync when I open the app, but still no notifications.  I have tried pretty much everything in this thread, and all the settings are set for notifications to come through.  I have cleared my cache and just now have tried the disable/enable suggestion above.  Fingers crossed it works.  how annoying.

0 Likes
Reply