JUMP TO SOLUTION Solved

Original topic:

Gmail not syncing!

(Topic created: 07-19-2021 01:24 PM)
Anonymous
Not applicable
Options
Galaxy S Phones

Hi everyone,
My GMail app is not syncing properly on Galaxy A02S (Notifications has no problem), Android 10, One UI 2.5 only when opening the app does the sync happens.
I've tried all and every tip about the issue. Things I've tried:

- Battery optimization for GMail is disabled
- Adaptive battery is disabled
- Data saver is disabled
- Gmail app is allowed while data saver is on (although the data saver is already off)
- Removing and Re-adding from Setting> Accounts
- It happens on every battery mode (optimized, medium power saving, maximun powr saving)
- I checked every setting both in GMail and Google Account
- Adding everything Google related to non optimized apps
- I disabled Auto sync data and then re-enabled
- I cleared GMail data and cache
- I did force stop the Gmail app, disabled it then re-enabled the Gmail app and restart phone
- I Uninstalled updates, then I cleared data and cache and updated the Gmail app again to latest version
- Putting Google DNS in WiFi setting
- I checked it using VPN but no success

The only workaround that makes me receive mail is opening the app and pull down from the top of inbox to refresh.
I think problem comes from Android version or Gmail app version.
Is there anyone that experiencing my problem? What do I do?
I don't want to do master reset or hard reset on my phone.
Sorry for my bad English and thanks.

10 Replies
Dchavez1
Astronaut
Options
Galaxy S Phones
First try to restart your device. Then check if is syncing
Anonymous
Not applicable
Options
Galaxy S Phones

- I did force stop the Gmail app, disabled it then re-enabled the Gmail app and restart phone

I did it more than 10 times but no success.

Blue7
Red Giant
Options
Galaxy S Phones

try removing the google account and add it again 

or try clearing cache and data 

GalaxyA02S
Constellation
Options
Galaxy S Phones

No success. I've tried all and every tip about the issue. Things I've tried is listed in my first post.

0 Likes
Reply
gnz
Asteroid
Options
Galaxy S Phones

I've solved it by adding my GMail account to Samsung's email app, then muting all notifications from that app so i could only get them from GMail app and not duplicated. It's the only thing that worked for me

Solution
GalaxyA02S
Constellation
Options
Galaxy S Phones

Hi,

Problem with Gmail syncing on my new Samsung phone was annoying.
Finally I solved the problem strangely!

Here is what you should do:
1. Connect to VPN (an Europe IP is preferred)
2. Turn off Auto sync data from Setting>Account
3. Add your account from Setting> Google> add account
4. Open your chrome app and login into the Email on your browser(gmail.com)
5. Now go to the Setting>Account and open the account is already added
6. Go to Sync account and do manual syncing
7. Open your Gmail app. Email is already added in your Gmail
8. Check your Gmail setting from left top menu in Gmail app
9. Scroll down and Find Sync Gmail then Turn it on and off then on
10. Turn on Auto sync data from Setting>Account
11. Go to Setting>Account, tap on your account then go to Sync account and do manual syncing
12. Open gmail.com on Chrome and send an Email to your Email (don't use different email to sending mail)
13. Wait at least 5 min to receiving new Email, It will be fast for next time if Syncing is successful
14. If it's not working try steps 2 and 5 to 10 again

It's not a cache problem, maybe it's an Android 10 or Gmail app bug. cache problem will solved with vpn or wiping data in recovery menu but here you have to TURN OFF "Auto Sync data" at first of things, also you have yo be logged in into your gmail account on your browser.

So be sure your VPN is connected during this process. (I checked It's not working without VPN and Auto Sync data should be OFF before account adding!)
Good luck.

View solution in context

0 Likes
Reply
Atlassheepdog
Astronaut
Options
Galaxy S Phones
I can't get my Gmail to sync either. The help service was no help. Guess I'll just use Gmail app and forget sync
0 Likes
Reply
Luckylove
Astronaut
Options
Galaxy S Phones
I have a Samsung
0 Likes
Reply
Luckylove
Astronaut
Options
Galaxy S Phones
I cant can't get on registered
Net work
0 Likes
Reply