Original topic:

Google Calendar not Syncing Part 2

(Topic created: 08-25-2021 09:46 AM)
Lacamastraveler
Constellation
Options
Galaxy S Phones

I have four devices; laptop, iPad and two Galaxy S21 Ultra 5Gs.

When I post a calendar event on the laptop or iPad, the event syncs to all the other devices.

When I post on either of the S21s the event does not sync to any device.

What I have tried:

This was listed as a solution, but did not work for me: settings / applications / special access / battery optimized apps and switch the list to all. After long browsing I found Calendar Synchronization and also Google Photos. I toggled the checboxes off .  

I have cleared data and cache, uninstalled the Google Calendar and reinstalled.  No help.

The sync worked fine on my previous S10.  

Any other solutions?  Thanks

8 Replies
usermkfokf5feu
Constellation
Options
Galaxy S Phones
You should go to settings, cloud and accounts, then accounts, choose Google account, and settings everything syn
0 Likes
LongHiker
Samsung Care Ambassador
Options
Galaxy S Phones

@Lacamastraveler On your S21's are you using the Samsung Calendar app? If so, make sure that when you add an event that you are picking the calendar associated with your Google account. 

It sounds like when you are creating events you may be using the default "My calendars" which is just local on your phone. 

0 Likes
userCDOgSH5OzG
Cosmic Ray
Options
Galaxy S Phones

Did any of the above steps worked?  what model carrier and sw version (settings > about phone > software information (last 4 digits of build number) do you have?

0 Likes
Lin8
Astronaut
Options
Galaxy S Phones
My samsung calendar is not syncing with my google account. I have repeatedly cleared cash, uninstalled, reinstalled, restart, check sync on everything. Everything is put into the right calendar account.
It continually stops syncing after a few weeks. It's so frustrating!!
0 Likes
SamsungJam
Community Manager
Community Manager
Options
Galaxy S Phones

Oh no!  This is bound to be frustrating.  By any chance is your phone updating prior to it losing that sync functionality?  .


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.

Lin8
Astronaut
Options
Galaxy S Phones
Yes, there was a recent update
0 Likes
SamsungRyder
Samsung Moderator
Samsung Moderator
Options
Galaxy S Phones

Have you tried toggling the synchronization back on instead of off and trying again? If that doesn't help, can you also wipe the cache partition? Give these steps a try: 

  1. Turn off the device.
  2. Press and hold the Volume Up key and the Side key.
  3. When the Android logo displays, release both keys.
  4. An 'Installing system update' message may show briefly before the Android Recovery menu options appear.
  5. Press the Volume down key several times to highlight Wipe cache partition.
  6. Press Side key to select.
  7. Press the Volume down key to highlight Yes, then press the Side key to select.
  8. When the process is complete, Reboot system now is highlighted.
  9. Press the Side key to restart the device.

Please let me know if it helps.

Lin8
Astronaut
Options
Galaxy S Phones
It's syncing right now, but i will try these steps.
Thank you
0 Likes