cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Bert Jansen
Asteroid

Hotspot on S7 not working

JUMP TO SOLUTION

The hotspot on my new S7 Edge is not working, I've tried with several devices and they all can connect but stumble on the same problem: no internet connection. When working with my Windows 10 Creators update version I'm getting DNS errors, so I gave the connection to the hotspot a fixed IP with a well-known DNS server but still a no go. Same behavior is visible when testing with another Android phone...connection but then "no internet".

 

The SIM card used did work perfectly on my previous phone (Windows 10 phone) without any issue, so it's not related to the mobile operator I think.

 

Model: SM-G935F

Android version: 7.0

All patches offered by Samsung are applied

1 SOLUTION

Accepted Solutions
Bert Jansen
Asteroid

Re: Hotspot on S7 not working

JUMP TO SOLUTION

 

Found a solution via https://androidworld.nl/forum/samsung-galaxy-s7-edge/67995-hotspot-ingesteld-en-krijg-geen-verbindin... (is in Dutch).

 

In summary, it's related to the provider internet configuration: Settings -> Connections -> Mobile Networks -> Access Point Names --> Select your provider --> click on "APN type". Mine was set to default,supl and after changing to * the problem was gone. Not even a reboot needed :-)

 

Hope this can help someone else as it took me a couple of hours to figure this out.

Reply
Loading...
14 REPLIES 14
Bert Jansen
Asteroid

Re: Hotspot on S7 not working

JUMP TO SOLUTION

Tried this: https://talk.sonymobile.com/t5/Xperia-Z5-Z5-Compact-Z5-Premium/Hotspot-not-working-after-update-to-A... but each time I enable hotspot the tether_dun_required setting is flipped back to 1. 

 

Any other options? Seems like a bug to me

Reply
Loading...
Bert Jansen
Asteroid

Re: Hotspot on S7 not working

JUMP TO SOLUTION

 

Found a solution via https://androidworld.nl/forum/samsung-galaxy-s7-edge/67995-hotspot-ingesteld-en-krijg-geen-verbindin... (is in Dutch).

 

In summary, it's related to the provider internet configuration: Settings -> Connections -> Mobile Networks -> Access Point Names --> Select your provider --> click on "APN type". Mine was set to default,supl and after changing to * the problem was gone. Not even a reboot needed :-)

 

Hope this can help someone else as it took me a couple of hours to figure this out.

Reply
Loading...
useroyLaZzNrED
Constellation

Re: Hotspot on S7 not working

JUMP TO SOLUTION

This solution worked on s8 7.0

Reply
Loading...
user2QJzpsjTVu
Astronaut

Re: Hotspot on S7 not working

JUMP TO SOLUTION

It solved the problem on S5 also.

Thanks

Reply
Loading...
useri40V9qGVU3
Astronaut

Re: Hotspot on S7 not working

JUMP TO SOLUTION

It still doesn't work on my s7........

Reply
Loading...
usergUGOHGMl5h
Constellation

Re: Hotspot on S7 not working

JUMP TO SOLUTION

Worked on my S7 after I changed "APN type " instead of APN. Oops.

Reply
Loading...
userDA9ACKtoXU
Astronaut

Re: Hotspot on S7 not working

JUMP TO SOLUTION

Changing APL from "default,supl,mms" to * worked for me, thanks.

Reply
Loading...
userveE6CB9DOE
Constellation

Re: Hotspot on S7 not working

JUMP TO SOLUTION

How did you change it, I ha e gone into the service provide which is three but everything is shaded out so you can't change anything?

Cheers

Reply
Loading...
userb8ZPtk3YcN
Constellation

Re: Hotspot on S7 not working

JUMP TO SOLUTION

Did you get an answer to this. I'm having the same issue...everything is grayed out...can't change anything

Reply
Loading...