Original topic:

Incoming calls showing private number even have in contacts

(Topic created: 08-30-2021 07:54 AM)
useryurTyZ6Bze
Astronaut
Options
Galaxy S Phones

Hi, 

Can any one help.

I am using s8  UK virgin network.

Caller Settings- caller id spam protection -ON

Supplementary services - show callerID also 

Other call settings also show caller information also enabled.

I tried all options even sim out and in and off as well. 

My incoming calls showing private numbers even i have in my contact list.

What can i do now ??

0 Likes
0 Replies