JUMP TO SOLUTION Solved

Original topic:

Loosing Mobile Data Connectio

(Topic created: 04-02-2020 12:37 PM)
SUNIL_KANETI
Asteroid
Options
Galaxy S Phones

 My phone has been acting very weird, i was previously with Ultra mobile and for mobile data, I have LTE coverage, but I can't browse the web or anything that uses the Internet doesn't work. I made and received a call though so that works. The signal switches back and forth between LTE, 3g and H+ coverage where the Internet worked briefly on 3g or H+, but it's not working when it returns to LTE. Thought it is an carrier issue and switched to Verizon yesterday but still the same issue.I tried resetting connections, safe mode, factory reset and shutting down my phone several times, that didn't help. Has anyone faced similar issue and any help is appreciated. 

2 Replies
Solution
Joellem
Product Expert
Options
Galaxy S Phones

hi @SUNIL_KANETI 

based on the description of your problem it seems that you have a hardware issue i would suggest getting it diagnosed by a Samsung service provider you can find one near your area by using this link

https://www.samsung.com/us/support/service/locations/

 

hopefully, this will help with your problem

Be sure to click " ✔ Accept as Solution" when you find an answer that works for you

View solution in context

0 Likes
SUNIL_KANETI
Asteroid
Options
Galaxy S Phones

Thank you, I reached out to the Samsung tech support over Twitter and they suggested the same. Right now we are in lockdown due to covid-19, once this settles, I will pay a visit to the store.

0 Likes