JUMP TO SOLUTION Solved

Original topic:

Phone contacts not showing on incoming calls

(Topic created on: 4/19/19 2:50 PM)
userWb4WZNe8w5
Constellation
Options
Galaxy S Phones
I have a galaxy s8 plus. When I receive incoming calls from a contact in my phone book only their number displays. But when I go in my recent calls both their name and number is there. Like most people I don't know everyone's phone number so when people are calling me, I dont know who they are until after I miss it. Ive already tried restarting my phone. No luxk And I checked for a software update. It's up to date.
51 Replies
SamsungJoJo
Samsung Moderator
Samsung Moderator
Options
Galaxy S Phones

@userDBsCR4Fbau Have you tried looking into the settings of the "Call Filter" to see if there are any options to show incoming calls? Also, If you don't mind providing a screenshot of that "Call Filter" settings so I can further look into this?

0 Likes
Reply
Samsung_A6FgXiI
Astronaut
Options
Galaxy S Phones

Even for the ppl that never set up the att call protect just hold down on the icon and disable it... PROBLEM SOLVED πŸ‘πŸΎ

userLiMptmztbl
Constellation
Options
Galaxy S Phones

Thank you! This helped

0 Likes
Reply
user5NpYdOiKNV
Constellation
Options
Galaxy S Phones

I have a Galaxy 8 in my phone would not charge even if this plugged up all night

0 Likes
Reply
userPLDECEZPM8
Asteroid
Options
Galaxy S Phones

It is an update glitch and another update should be out in a few days. Spoke to a pro tech at AT&T.

Samsung_ikyttxm
Astronaut
Options
Galaxy S Phones

Thank you it worked !!!

0 Likes
Reply
Msjenn
Constellation
Options
Galaxy S Phones

Me too. Is it a Samsung issue or Att issue??

0 Likes
Reply
userULNZNg9NBx
Astronaut
Options
Galaxy S Phones

I been having the same issue. Go to your settings, then apps. Find the app Call Protect, force stop then disable it. Fixed my issue.

0 Likes
Reply
Fishy14
Constellation
Options
Galaxy S Phones

Okay so this is what worked for me after reading what people suggested. I have a galaxy S8+ through AT&T and I've had this issue since day one, I also got this phone about a week or two ago. I had to go to Settings > Apps > Call Protector or AT&T Call Protector and disable it (Call Protector is the updated version of AT&T Call Protector) some people were saying you have to disable both but you should only have one. Either way you have to disable which ever version of the app you have. If you have the updated version so just the one the says Call Protector when you disable it, it'll disappear and AT&T Call Protector will pop up, make sure that is disabled as well (it should be). Re-start your phone and test it out, it should most definitely work.

0 Likes
Reply
usert9viYVrvdq
Astronaut
Options
Galaxy S Phones

Open Apps and click on ATT. Under ATT there should be an app called "call protect". Uninstall it, don't just disable it. Then go into SETTINGS, then under  DEVICE MAINTENANCE click on MEMORY. Then click on CLEAN MEMORY and you should see it clean up the "call protect" file. Then reboot the phone. It worked for me.

0 Likes
Reply