JUMP TO SOLUTION Solved

Original topic:

Phone contacts not showing on incoming calls

(Topic created: 04-19-2019 02:04 PM)
userWb4WZNe8w5
Constellation
Options
Galaxy S Phones
I have a galaxy s8 plus. When I receive incoming calls from a contact in my phone book only their number displays. But when I go in my recent calls both their name and number is there. Like most people I don't know everyone's phone number so when people are calling me, I dont know who they are until after I miss it. Ive already tried restarting my phone. No luxk And I checked for a software update. It's up to date.

1 Solution


Accepted Solutions
Solution
SamsungRei
Samsung Moderator
Samsung Moderator
Options
Galaxy S Phones

Hey guys,

Go to your Settings>Applications>Search for an application called "Call Protect".


When you open it, select Force stop.




Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.



Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

View solution in context

51 Replies
SamsungRei
Samsung Moderator
Samsung Moderator
Options
Galaxy S Phones

Who is your service provider?



Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.



Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

0 Likes
Reply
userUKsVzVbLS0
Astronaut
Options
Galaxy S Phones

Mine started doing this today also. I have att

userwG9ASodHxV
Constellation
Options
Galaxy S Phones

Mine issue started last week after an update. I too have AT& T.

0 Likes
Reply
userhGnQakb7Gn
Constellation
Options
Galaxy S Phones
Started for me a few days ago.. I have att
userpRna4U9Jmm
Astronaut
Options
Galaxy S Phones

Did anyone find a solution that works? 

0 Likes
Reply
userUKsVzVbLS0
Astronaut
Options
Galaxy S Phones

I'm having this same problem. It started this morning. I have att.

user4pjNWrGZpq
Asteroid
Options
Galaxy S Phones

Mine started 2 days ago and i have att

SamsungRei
Samsung Moderator
Samsung Moderator
Options
Galaxy S Phones

Have you tried toggling the settings of Call Protect?



Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.



Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

0 Likes
Reply
user4pjNWrGZpq
Asteroid
Options
Galaxy S Phones

I do not know what that means.