JUMP TO SOLUTION Solved

Original topic:

S10e won't send MMS with WiFi on

(Topic created on: 8/13/20 9:59 AM)
user63J5YhnY6s
Asteroid
Options
Galaxy S Phones

I have an S10e on Xfinity mobile with the stock messaging app, it won't send MMS messages at all anytime WiFi is turned on. Even if mobile data is still on, it won't send. From everything I've read this is a known issue and effects everything from the S8 up since OneUI and Pie were rolled out. If this a carrier issue, a Samsung issue, or what? Everyone is passing the blame and nothing says how to fix it. Please help!

RedDragon
Samsung Care Ambassador
Options
Galaxy S Phones

@user63J5YhnY6s i dont know if xfinity has this but on stock messaging app can you check the Message Center Number if ever xfinity has it and then check their website if it's the right number? It should start with "+" sign.

0 Likes
Reply
userFCGWRvF5Od
Astronaut
Options
Galaxy S Phones

Found a solution ....other may want to try with their S 10 . Brief backgound....home has NO cell service ( sits in a mountain valley) For YEARS I had an LG phone with wifi calling through Verizon and it would text ANYTHING instantly through my house wifi and land line.  Recently switched to US Cellular and a new Galaxy S 10.  After setting up everything correctly I tried texting through my wifi line land . Sometimes they went ...in a few minutes , sometimes not for an hour .  Read all these problems online that everyone seems to be having ....changed my messaging app ....even tried the Verizon Message + that worked fine on my old phone and still NOTHING . Finally started digging deeper into my wifi settings on the S 10 .   Opened "settings" icon and then clicked on "connections"  opened my home wifi connected which I was connected to under current network. There is a little "gear wheel" to the right of my named connection, pressed it to open another "settings" page for my conection .  On the bottom of this page is an "Advanced" tab. OPEN IT  !  There is a setting called "Metered network"   Mine was originally set ( probably from the factory) as "Treat as metered". Open that tab and set it to "Treat as unmetered"   , Save and exit !!   PROBLEM SOLVED !!  Texts ANYTHING now INSTANTLY !!!   LOVE this phone !  Was going to hate to have to return it because of the texting issue ! 

userJ6znFx3bEy
Astronaut
Options
Galaxy S Phones

Holy cow. I've been trying to fix this issue forever. Changing to unmetered fixed mine right away. Thanks for that. 

0 Likes
Reply
useryWcJDNhmoP
Asteroid
Options
Galaxy S Phones

I called Samung today and the first level support knew nothing of the issue.  They told me second level support was closed due to the corona virus.  Sigh. 

0 Likes
Reply
user5XycFabDOR
Astronaut
Options
Galaxy S Phones

Just bough Samsung S10e (Had an S7 Edge before)  Couldn't and still cant send a PDF as a text.

Just now - using suggestions and changing to unmetered on S10e.

WiFi OFF - Won't send.

WiFi On - Won't send

WiFi "Calling" OFF - Won't send.

WiFI "Calling" ON - Won't send.

I'm not terribly techy but would love to have a solution for this.  It's frustrating.

 

 

0 Likes
Reply
USAMAC
Constellation
Options
Galaxy S Phones

@Lithium-AdminPlease pin this as the answer for this problem. This is a very strange problem that seems to have something to do with Samsung and/or carriers pushing a security update, enabling Metered Connection on home wifi.

 

I have a full Unifi setup at home that is way underloaded and my wife nor I on Samsung S10's, all of a sudden recently could not send a picture through text to each other. My wife was ready to sell her phone and go back to her iPhone.

 

This is poor management on Samsungs part. Push a request to enable, but force enable?  Unsat.

0 Likes
Reply
Hostirad
Asteroid
Options
Galaxy S Phones

OMG I have been all over so many different message boards trying to solve this problem and finally get a solution that works! Thank you!

atehrani
Asteroid
Options
Galaxy S Phones
Thank you this fixed our issue!!
0 Likes
Reply
userZYnSVfpu93
Asteroid
Options
Galaxy S Phones

Omg! I think this is going to work! I've been searching for a fix for over a year. It has happened off & on with 4 different Samsung phones. Mostly with AT&T SIMs.
I used to think it was due to wifi calling but recently pics will only download when wifi is off (& wifi calling left on). If this fix lasts, I'm going to give you credit & post your fix all over. So much appreciate your post!

 

Update (half a day later). I'm sad to report that this fix did not end up working. I was using Google Android Messages and the first 2 sets of pictures came right in but after that, backStock Samsung Messages app and it was working for one picture download and then now, it once again kept trying to download, spinning & spinning. Closed the Messages app, reopened and still wouldn't download. Turned Wifi off and the picture downloaded immediately. This problem is on an Unlocked Glaxy Z Fold 2 with AT&T but I've had this issue on 2 S10e's & Note 10+. 

0 Likes
Reply
usercGq4Rjp5L8
Constellation
Options
Galaxy S Phones

I'm having the same problem. AT&T service, Galaxy 20 FE, brand new phone. Messages come in but won't download if I'm on WiFi. Turn it off, click download and it works. Tried changing to unmetered, called into AT&T support a dozen times, nothing is working. 

0 Likes
Reply