JUMP TO SOLUTION Solved

Original topic:

S10e won't send MMS with WiFi on

(Topic created on: 7/22/19 1:36 AM)
user63J5YhnY6s
Asteroid
Options
Galaxy S Phones

I have an S10e on Xfinity mobile with the stock messaging app, it won't send MMS messages at all anytime WiFi is turned on. Even if mobile data is still on, it won't send. From everything I've read this is a known issue and effects everything from the S8 up since OneUI and Pie were rolled out. If this a carrier issue, a Samsung issue, or what? Everyone is passing the blame and nothing says how to fix it. Please help!

38 Replies
RedDragon
Samsung Care Ambassador
Options
Galaxy S Phones

@user63J5YhnY6s Are you saying you have no LTE coverage and use wifi-calling and MMS did not go through? Did you check your APN settings? is wifi calling fully working? to find out if wifi calling works put your device in airplane mode then turn on Wifi and turn on wifi-calling.

0 Likes
Reply
user63J5YhnY6s
Asteroid
Options
Galaxy S Phones

No, cellular data and connection are good, full bars. Since I happen to be at my home or somewhere with an Xfinity hotspot, or WiFi I will also be connected to that. Web surfing, email, everything works fine except sending MMS. I have to turn WiFi off entirely in order for any messages to send.

ChrisWNY
Samsung Care Ambassador
Options
Galaxy S Phones

Some carriers have issues with Wifi calling. Disable Wifi calling, then try sending some MMS messages with Wifi calling disabled and let us know if that makes a difference.



If you've found my post to be helpful, please like the post. If my response helped resolve your issue, please press the "✓ Accept as Solution" button. Thanks!

0 Likes
Reply
user63J5YhnY6s
Asteroid
Options
Galaxy S Phones

WiFi calling was never enabled on this device, so that isn't the issue. After turning on WiFi calling, that feature works fine

user63J5YhnY6s
Asteroid
Options
Galaxy S Phones

After messing with different settings it still would not send. Tried sending images, waited about 5 minutes, nothing. Turned WiFi off so it's strictly mobile data, sent immediately. Turned on Roaming Auto Retrieve, sent a picture with WiFi on in just over a minute. Tried sending a GIF, went to 5 minutes without sending.

userMoSNSQCePE
Asteroid
Options
Galaxy S Phones

I don't have a problem sending MMS, my problem is downloading with wifi on. This has been going on for months and doesn't seem to be any solution. You name it I have tried it, everything from factory reset to new sim card. I have a note 10+ with xfinity.

userXTmPIVetD6
Astronaut
Options
Galaxy S Phones

This is the exact same problem both my wife and I have with our Galaxy S20 5Gs.  I still have not found a way to resolve this issue and it's apparently been going on for over 6 months.  Very frustrating.  I cannot download any MMS images sent to me when connected to any WiFi network.

0 Likes
Reply
userayFnq1Ca3y
Astronaut
Options
Galaxy S Phones
I have the same problem. We're you able to resolve? I have the Note 20Ulta my husband Note 10+ if our WiFi is enabled and running, we cannot send or receive pictures or GIF. as soon as wifi turns off, no problem. don't know how to fix I.
0 Likes
Reply
user63J5YhnY6s
Asteroid
Options
Galaxy S Phones

We've checked and verified WiFi calling. It was off at first, turned it on and WiFi calling works properly.

0 Likes
Reply