JUMP TO SOLUTION Solved

Original topic:

S8 automatically goes to speaker phone

(Topic created on: 6/22/17 10:23 PM)
Ikenna
Asteroid
Options
Galaxy S Phones

Whenever I answer the phone it automatically goes to speaker phone. HELP!!! 

0 Likes

1 Solution


Accepted Solutions
Solution
Ikenna
Asteroid
Options
Galaxy S Phones

Looks I was able to fix the problem. This is how: 1) since a third party app was the problem I looked through the apps that had permission to  my "phone" and my "microphone" since that was where the problem was  2) I started denying permission to apps and then calling to see if the app I turned off was the problem. When it wasn't I repeated the same process with other apps. 3) Once I found out what app was causing the problem I made sure that I denied permission for that app to the phone. For me this app was TouchPal. Thanks for your help! 👍🏾

View solution in context

7 Replies
SamsungMarcos
Neutron Star
Options
Galaxy S Phones

May I ask which phone you have? Let's start with the model number and we'll go from there.


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you. If a post stand out to you, perhaps you could give that post a star to show other community members they were able to assist or was relevant to you.

Ikenna
Asteroid
Options
Galaxy S Phones

I have a Samsung Galaxy S8: model number SM-G950U

SamsungMarcos
Neutron Star
Options
Galaxy S Phones

Okay, this very well could be caused by a third party app without you even knowing it. Let's have you put your phone into Safe Mode to rule that out, and test to see if it happens again should you answer a call.

 

To put your phone into Safe Mode, you can check out the guide I wrote up, which makes it super simple to do - S8 Specific | How To: Safe Mode, Reset Settings, and Cache Wipe


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you. If a post stand out to you, perhaps you could give that post a star to show other community members they were able to assist or was relevant to you.

Ikenna
Asteroid
Options
Galaxy S Phones

Yeah so I put it into safe mode and the problem was fixed. How do I know what app is causing it and how do I make a permanent fix in regular mode? 

Solution
Ikenna
Asteroid
Options
Galaxy S Phones

Looks I was able to fix the problem. This is how: 1) since a third party app was the problem I looked through the apps that had permission to  my "phone" and my "microphone" since that was where the problem was  2) I started denying permission to apps and then calling to see if the app I turned off was the problem. When it wasn't I repeated the same process with other apps. 3) Once I found out what app was causing the problem I made sure that I denied permission for that app to the phone. For me this app was TouchPal. Thanks for your help! 👍🏾

View solution in context

SamsungMarcos
Neutron Star
Options
Galaxy S Phones

Awesome! Happy to hear you were able to track down the app responsible. 


Be sure to click " ✓ Accept as Solution" when you find an answer that works for you. If a post stand out to you, perhaps you could give that post a star to show other community members they were able to assist or was relevant to you.

userFHJdvZelNk
Asteroid
Options
Galaxy S Phones

Had the same issue.

After debugging I found that Microsoft Teams causing it. After I uninstalled it, the issue was fixed.

 

If that's the same for you - please upvote this bug in MS Teams forum

https://microsoftteams.uservoice.com/forums/908686-bug-reports/suggestions/40803688-speaker-phone-au...

0 Likes