JUMP TO SOLUTION Solved

Original topic:

Slow to non-existent internet

(Topic created on: 12/5/20 8:31 AM)
Owlconundrum
Asteroid
Options
Galaxy S Phones

I have a weird issue right now. Just had new cable lines installed to fix my internet at my home. Now internet tests on all devices work except for my phone. When my Galaxy S8+ connects to the wifi, it will act as if I am connected to dialup and never load anything. My phone seems to work fine with other routers and hotspots, but not this, and this only started happening over the past couple of months. It is only my phone that this is happening with. I am at a loss. Has this happened to anyone, and how did you fix it. Trying to find a solution that doesn't involve a factory restart my phone.  The router is an xFi router from Xfinity. No one else is having issues with the router on their phones or computers.

0 Likes
Reply

1 Solution


Accepted Solutions
Solution
Owlconundrum
Asteroid
Options
Galaxy S Phones

I managed to figure it out. I needed to assign a static IP to my phone for my wifi. 

View solution in context

3 Replies
Options
Galaxy S Phones
Try resetting the wifi connection by going into settings, connections, wifi, your wifi connection, and selecting 'forget.' Then connect again. You'll need to reenter you login information again.
0 Likes
Reply
Owlconundrum
Asteroid
Options
Galaxy S Phones

Thanks for the suggestion,  but I'm still having issues. 

0 Likes
Reply
Solution
Owlconundrum
Asteroid
Options
Galaxy S Phones

I managed to figure it out. I needed to assign a static IP to my phone for my wifi. 

View solution in context