Original topic:

WiFi Calling does not work after Auto Restart

(Topic created: 07-17-2021 02:26 PM)
userfZu2uF4Mdr
Asteroid
Options
Galaxy S Phones

Can you please forward this to the Samsung Cell Phone Galaxy Engineer for action

I am reporting a bug that needs to be corrected with the next Samung Update please. The problem occurs on 2 different Samsung devices one device is my wife’s and one device ismine. This problem occurs despite doing a hard reset on the devices. Let me explain the problem that occurs on both devices. My Wife own a Samsung Galaxy S10+ and I own a Samsung Galaxy Note 10+ (both unlocked and are both are not branded to any cellular carrier)

 

Let me explain to you and please read this very very carefully so you can understand clearly the issue at-hand:

 

We do not have good cellular coverage indoors at our home, therefore we must use Voice Over WiFi feature known in the Samsung device as: Wi-Fi Calling and the feature is turned ON on both of our devices and the WiFi Calling PREFERENCE is set to Wi-Fi PREFERRED on both devices. While we are at home, indoors, we communicate with our phone calls via the WiFi Calling feature on both of our devices as our Wi-Fi Internet is provided by Spectrum Internet Company. The WiFi internet from Spectrum Internet Company is working perfectly fine and all ports on the WiFi router are open and there is no issue with the WiFi Internet nor WiFi router.

 

Keep paying attention please. Both of our devices features are set to: AUTO RESTART AT SET TIMES (toggled ON). We have this feature to “AUTO RESTART DEVICE AT SET TIMES” toggled ON on both devices at 3 AM (while we are asleep, so devices auto restart at 3 AM while we are asleep.)

 

Keep paying attention please here. Both of our devices also have: SCREEN LOCK TYPE set to PIN, which means when our devices reboot or sreen locks after 5 minutes (set to lock after 5 min on our devices), in order to unlock the screen on our devices and use the device and use the apps and be able to call, the end-user (me and my wife) must enter a PIN (which we have set) to unlock our devices’ screen and have access to all apps on our devices etc... In fact, when we restart our devices during the daytime, with the SCREEN LOCK TYPE set to PIN on both of our devices, after this restart, the System UI (User Interface) screen message populates on both of our devices stating: “PHONE RESTARTED. UNLOCK YOUR PHONE to GET APP NOTIFICATIONS.” And as soon as we enter the set PIN, devices’ screen unlocks and we now have access to the devices’ apps and able to use device and call via Phone App via Wi-Fi calling (if we are at home) etc...

 

Here is the issue at-hand. Please keep reading carefully.

 

Because both of our devices are set to “AUTO RESTART AT SET TIMES” at 3 AM, we are asleep and we can not unlock our devices’ screen, with our set PIN, until we wake up at around 6AM in the morning. What is happening with both of our devices is: the WiFi calling does not work upon that auto-restart at 3 AM therefore any calls coming in at 3 AM, and after 3 AM, go directly to voice mail and are missed. In fact, when we wake up at 6 AM and see that our devices auto-restarted at 3 AM same nite, and despite our entering the PIN to unlock the screen on our devices, the WiFi Calling feature remains not connected and we are still unable to make calls. What we must do, after devices auto restart at 3 am, is we must enter PIN to unlock screen and then RESTART our devices again (or put our devices in the AirPlane Mode for 30 seconds and then toggle airplane mode OFF) to be able to call and use Phone App on our devices. In Summary: After device auto restarts at 3 AMhave and stays auto restarted without end-user entering PIN to unlock screen for device to finish restart, the WiFI calling feature no longer active and end-user without cellular coverage indoors (like me and my wife) will not be able to get or make phone calls. HOWEVER: If the device auto-restarts at 3 AM and end user immediately PIN to unlock screen, the auto restart will complete and WiFi Calling will work. Please understand the auto-restart does not turn off the wifi calling feature, as the WiFi calling feature remains toggled ON after auto-restart. The WiFi calling featureto work requires the end-user with PIN set to unlock screen, must unlock screen to have WiFi calling work indoors without cellular coverage. If end-user does not enter PIN to unlock screen after auto-restart of the device, the WiFi calling is not available until end-user enters screen unlock PIN for the phone to complete the restart process and only then the WiFi calling feature will work.

 

I contacted our cellular carrier and I was told that all our WiFI calling features are turned ON on their end and I contacted my WiFi Internet Carrier and was told no ports are blocked.

 

In fact, my WiFI calling works perfectly during the day. The issue happens ONLY after auto-restart at night with the PIN set unlock screen. Unless PIN is entered at night immediately after auto-restart of the device, the WiFI calling feature will NOT work and all calls at night after auto-restart will be missed.

 

I think Samsung mustissue an update after Samsung corrects the program to code for the WiFI calling feature to continue to work WITHOUT end-user entering screen unlock PIN after AUTO-RESTART.

By the way, all phones are uptodate with updates.

 

Please let me know if you need any additional information.

 

My IMEI 359187100373994 and my wife’s IMEI 352689104952282

 

Thank you,

Roman Greenspan.

RomanGreenspan@yahoo.com

0 Likes
1 Reply
Smew
Nebula
Options
Galaxy S Phones

I understand it's inconvenient to have to unlock following auto restart in order to receive wifi-calling calls but it doesn't seem like a software issue but more like a software design concept that is standard across all devices. 

If you suspect a software defect then the best thing to do at first is submit an error report through the Samsung Members app.

Another thing you can consider doing is setting up a custom Bixby Routine that will disable the need to use a pic (if it's possible, definitely worth a try).

good luck! 

0 Likes