Original topic:

Yellowish Display

(Topic created: 03-24-2019 02:31 AM)
denisecampos
Asteroid
Options
Galaxy S Phones

Hi guys, I just switched to the Samsung Galaxy S10 a couple of days ago, and the first thing I noticed that it has yellowish display? First thing I fiddled on were the display settings, but can't seem to get it white at all. I've read some of the threads here, some say it's the pre-installed screen protector? Help please. If there isn't a change at all if I peel that off, then I'd rather keep it on. 

1 Solution


Accepted Solutions
Solution
Leinz
Samsung Care Ambassador
Options
Galaxy S Phones

Screenshot_20190324-103525_Settings.jpg

After disabling blue light as they mentioned, switch to vivid mode and try this setup. This is what I use on my S10+; altho I didn't experience a yellowish tint before. 

 

Also the screen film does not affect colors shown, since it's a transparent sheet. 


If my reply has aided your issue please consider liking it. If the problem is solved you may pick it as a solution.

View solution in context

10 Replies
SJohnson
Samsung Care Ambassador
Options
Galaxy S Phones

Try going into settings> display> screen mode. Also check if your blue light filter isn't enabled

 

Screenshot_20190324-062156_Settings.jpg

 



Please follow all community guidelines before posting


Solution
Leinz
Samsung Care Ambassador
Options
Galaxy S Phones

Screenshot_20190324-103525_Settings.jpg

After disabling blue light as they mentioned, switch to vivid mode and try this setup. This is what I use on my S10+; altho I didn't experience a yellowish tint before. 

 

Also the screen film does not affect colors shown, since it's a transparent sheet. 


If my reply has aided your issue please consider liking it. If the problem is solved you may pick it as a solution.

View solution in context

denisecampos
Asteroid
Options
Galaxy S Phones

Tried playing around with the RGB setting and it made a slight difference. Still not as white as expected. How is your display? Really white when it comes to white backgrounds? Or maybe I'm just used to Huawei's display

0 Likes
Reply
leahcal81
Constellation
Options
Galaxy S Phones

Its gotta be the blue light filter for night time settings right?

0 Likes
Reply
denisecampos
Asteroid
Options
Galaxy S Phones

Nope, definitely not the blue light filter.

0 Likes
Reply
userHlcnGHh3tU
Constellation
Options
Galaxy S Phones

I've got the solution from a separate discussio: TURN OFF night light from Google Play Books.

 

Worked 100% for everyone that has same issue.

0 Likes
Reply
useryZtCiIgWRi
Constellation
Options
Galaxy S Phones

I called Samsung and they suggested to have turn on HDR. I think my pictures are better now.

 

0 Likes
Reply
user3SlqgfWHS0
Astronaut
Options
Galaxy S Phones

Cracked it. Tried all that's mentioned here, & it didn't help. Samsung Service Centre asked to reset it. Didn't help. Finally, I did the following, & it worked -

 

Factory Reset

Did not log in with my Google Account, or Samsung Account

Therefore, did not transfer information & settings from my previous Samsung phone / Google account at Startup

Logged in to Google only later, after completing the setup

 

And the yellow tint has gone. Though, is crazy that this should happen, & Samsung should correct the glitch.

0 Likes
Reply
userye1bQhOBPz
Astronaut
Options
Galaxy S Phones

This is quite weird it happened to me today too. 

Is there any other way to fix this samsung? 

 

0 Likes
Reply