Original topic:

galaxy watch showing voicemail notification won't go away on watch only

(Topic created on: 5/3/21 12:04 PM)
usermdNQjrVKuw
Constellation
Options
Galaxy S Phones

Hey guys,

 

I have a Galaxy Watch SM-R805U from T-Mobile and for a while now it keep showing i have a VM on my watch and not my phone. When i check the VM via watch or phone there are NO messages saved or otherwise. i have unpaired and tried just using the watch and or phone and neither have a VM when calling. Yet my watch regularly says i have a VM pending and i don't.

 

I have even reset the watch and still it pops up. There shows no software updates either.

 

Thoughts?

Thanks

 

~Brad~

28 Replies
Skin314
Constellation
Options
Galaxy S Phones

I got this issue to resolve for me by going into the Gear App and Removing the watch all together by using the app. This will reset the watch and when I reconnected everything it clear the persistent VM notification. I hope this will work for you. 

0 Likes
Dpcharles23
Astronaut
Options
Galaxy S Phones
If your watch has its own cell service, disconnect the Bluetooth and call the number that's associated with the watch. Leave yourself a voicemail, then using the watch call the voicemail and delete the one you just left. It will remove that notification, just worked for me.
0 Likes
user4zNYzRA202
Constellation
Options
Galaxy S Phones

I've had this issue on my watch as well. Tried everything. Turned off voicemail notifications but it would disable text messages as well. I would get voicemail notifications every 20 min lol

 

Once thing I did that seems to work:

My voicemail notifications come as a text message from a 446-1 number which is same one that always comes on my watch. From my phone I found that message and blocked the number. Since then I haven't received those annoying messages on watch anymore.

0 Likes
user6OTuLh97D5
Asteroid
Options
Galaxy S Phones
same issue as everyone here
None of the recommendations working for me. it's 1.7.21 and my message notification says it's from 10.10.2020.
shame samsung hasn't fixed this bug
0 Likes
userGMRq7q8V1o
Astronaut
Options
Galaxy S Phones

I had this issue for a week. This is how I resolved it.
In the galaxy watch app, go to mobile plans. In the top right overflow menu (three dots) select "Reset all your mobile plans?" 
Follow the directions and then re-add the mobile plan to your watch. The app makes the whole process very streamlined. 

0 Likes
userpTPCuobQeq
Constellation
Options
Galaxy S Phones

I'm guessing it is a T-Mobile / Samsung issue.  I was on Sprint for 20 years without the issue.  I switch my SIM card to T-Mobile about 3 months ago, and the problem started then.
1.  The notifications are coming from the "Phone" app, not the Visual Voicemail app.

2.  You cannot disable VM notifications for your Phone App under Settings -> Phone.  Disabling them is greyed out.

3.  I disabled "Phone" notifications from the Samsung Wearable App.  This fixes the VM issue, however, it also blocks the ability for you to answer your calls with your watch.  (i.e. when you get a call on your phone, your watch isn't notified at all.)  This is not an acceptable solution.

0 Likes
Sh1ggy
Astronaut
Options
Galaxy S Phones
Disconnect from Bluetooth on your phone and let the watch reconnect to t-mobile service. Your watch will start buzzing as old messages start coming through. Then swipe left on your watch and DELETE ALL. Finally, turn on Bluetooth on your phone and reconnect the watch. Works for me every time.
0 Likes
userpTPCuobQeq
Constellation
Options
Galaxy S Phones

Thanks for the information.  What do you mean "Works for me every time?".    Does this mean you get this problem all the time and doing this clears them out for a while until they pile up again?

0 Likes
Sh1ggy
Astronaut
Options
Galaxy S Phones
Yes, its super annoying! Every time I get a voicemail notification it stays on the watch after trying to Delete. I find it best to do it at the end of each day.