cancel
Showing results for 
Search instead for 
Did you mean: 
userVCQLMijt2s
Constellation

Charging port smells burt

JUMP TO SOLUTION

My charging port no longer lets me charge my phone I have to do it wirelessly and every time I put my phone to charge through the port it says moisture detection I have no idea what to do

1 SOLUTION

Accepted Solutions
Highlighted
Samsung Care Ambassador

Re: Charging port smells burt

JUMP TO SOLUTION

That is because your charging port has been short circuited. The Fail-Safe inside of your phone didn't go off in time then the electrical circuit mixed with moisture. I would recommend taking this into your nearest service center if there is not a Samsung repair center near you



View solution in original post

Reply
Loading...
4 REPLIES 4
Heavywey
Asteroid

Re: Charging port smells burt

JUMP TO SOLUTION

Put in rice 🤷🏾‍♂️

Reply
Loading...
Highlighted
Samsung Care Ambassador

Re: Charging port smells burt

JUMP TO SOLUTION

That is because your charging port has been short circuited. The Fail-Safe inside of your phone didn't go off in time then the electrical circuit mixed with moisture. I would recommend taking this into your nearest service center if there is not a Samsung repair center near you



View solution in original post

Reply
Loading...
Fantasma_
Astronaut

Re: Charging port smells burt

JUMP TO SOLUTION

Have you tried to clean the charging port?

Reply
Loading...
Volkswagen7
Cosmic Ray

Re: Charging port smells burt

JUMP TO SOLUTION

@SJohnson

OK, please tell me then, what are the mathematical chances that the same thing happens to me with less than a month on two different devices. Same model> note8, just got a replacement.

Last phone ended up being bricked.

Brand new cables (actually makes no difference what cables I use) being at home and no chance of any moisture getting to my phone?

Summer is over so no humid air.

Please tell me. Then I will give you my thoughts.

Edit; Since I see that the same problem occurs with 8/9/10 it makes no difference where I post this issue imho 

Reply
Loading...