cancel
Showing results for 
Search instead for 
Did you mean: 
userRQ63k1JIKh
Constellation

Re: Inernet on S10 is wokring slow while using Network Data

JUMP TO SOLUTION

Hey bro do you still face this issue ? Because I have the same exact issue with my s10+ (exynox) it reaches 2-3 mbs while my note 9 reaches 40+. I have this bug in my s10+ . I think it is a software issue 

Reply
Loading...
user66LBGa7cDu
Constellation

Re: Inernet on S10 is wokring slow while using Network Data

JUMP TO SOLUTION

Same issue as this with my S10

Reply
Loading...
NGConnect
Asteroid

Re: Inernet on S10 is wokring slow while using Network Data

JUMP TO SOLUTION

Ya, the issue is still exist.  :-(

Reply
Loading...
Highlighted
userfRan6WroDP
Constellation

Re: Inernet on S10 is wokring slow while using Network Data

JUMP TO SOLUTION

Same issue with my S10. Speedtest shows 20Mbps. When I turn wifi off and back on, speedtest shows 155Mbps. A little while later it goes down to 33Mbps. I turn wifi off and on again and the speed goes to 175Mbps. This is clearly an S10 wifi problem.

Reply
Loading...
CANIEATUNOW
Constellation

Re: Inernet on S10 is wokring slow while using Network Data

JUMP TO SOLUTION

same here I just got this phone on Monday my signal only has 2 bars I'm going back to my s7

Reply
Loading...
CANIEATUNOW
Constellation

Re: Inernet on S10 is wokring slow while using Network Data

JUMP TO SOLUTION

I did everything from factory reset to erasing the cache still my signal strength low...s10e

Reply
Loading...
Musclehead84
Constellation

Re: Inernet on S10 is wokring slow while using Network Data

JUMP TO SOLUTION

Same here. Upgraded from the Galaxy S8 and both my daughter's and my S10 LTE is not as good as the S8. It was a known issue and supposedly the last update was to fix it but it didnt. Terrible for such a nice phone.

Reply
Loading...
mkenny28
Cosmic Ray

Re: Inernet on S10 is wokring slow while using Network Data

JUMP TO SOLUTION

@NGConnect wrote:

I am using S10 and with this I am facing slow internet speed (when it is showing full network).

  1. My friend is using oneplus 6 with same network provider and same plan.
  2. Most of the time my scanning apps like PayTM, Google Pay are not working and at same place his apps are working fine.
  3. For me apps showing it is due to slow internet connection.
  4. Any one facing this issue?
  5. Please do reply on this if any one facing the same issue. So that we can discuss with Samsung member/custmore care. 

Already a huge thread on this. https://us.community.samsung.com/t5/Galaxy-S10/Re-Mobile-data-and-wifi-issues-All-Carriers/m-p/47856...

Reply
Loading...
Gabbyy
Astronaut

Same thing happened with s10e try to hard reset should fi...

JUMP TO SOLUTION

Same thing happened with s10e try to hard reset should fix the problem

Reply
Loading...
user26xa1j2ZX5
Constellation

Restart Phone

JUMP TO SOLUTION

Restart Phone

Reply
Loading...