cancel
Showing results for 
Search instead for 
Did you mean: 
useru6pyyc2bcW
Constellation

No LTE/dropping data after G975USQS2BSIA [SPRINT]

I'm not new to the S10 and data issues. This is my second S10, my first was one of the launch ones that was defected and had to be replaced. I had this phone for about 6 months, not alot of issues. On 10/1/19 I accepted the Software Update G975USQS2BSIA. Biggest mistake!

 

Since then I been having data drops left and right. No LTE in known places, complete network drops. Its like I have a defected phone again. 

 

If Samsung doesn't acknowledge this problem and roll out a fix, I'll probably just claim this on insurance and sell it new and buy a better phone. I'm tired on Samsung rushing unfinish/untested products to market.

 

Any troubleshooting help is much appreciated!

1 REPLY 1
Highlighted
Honored Contributor

Re: No LTE/dropping data after G975USQS2BSIA [SPRINT]


@useru6pyyc2bcW wrote:

I'm not new to the S10 and data issues. This is my second S10, my first was one of the launch ones that was defected and had to be replaced. I had this phone for about 6 months, not alot of issues. On 10/1/19 I accepted the Software Update G975USQS2BSIA. Biggest mistake!

 

Since then I been having data drops left and right. No LTE in known places, complete network drops. Its like I have a defected phone again. 

 

If Samsung doesn't acknowledge this problem and roll out a fix, I'll probably just claim this on insurance and sell it new and buy a better phone. I'm tired on Samsung rushing unfinish/untested products to market.

 

Any troubleshooting help is much appreciated!


Try APN reset:

Check if your carrier settings are good, go to: settings>connections>mobile networks and check settings there. Then go to access point names.  Make sure proper carrier is selected or you can even tap 3 dots on top right and do reset to defaults.


Reply
Loading...