cancel
Showing results for 
Search instead for 
Did you mean: 
usercmL5b2HHDX
Constellation

S10e OTG Controller doesn't work...or does it?

Scenario:

Using the OTG connector that comes with the s10e and an 8bitdo SN30 Pro USB controller(new - no bluetooth)

 

OS: Pie - Update to 10 is not available on my carrier yet.

 

Results: 

The controller is recognized and is powered on but pretty much every app I have tried to use it with doesn't recognize any key presses.

 

Steps taken:

Updated the controller to the latest firmware - no change

Tested on my Pixel 1 - works perfectly

Tested a mouse and USB drive with the same OSG adaptor and the s10e - works

Tested xbox 360 wireless adaptor with same OSG adaptor and the s10e - lights up but won't pair with the 360 controller

 

The one and only app so far that seems to recognize the 8bitdo controller AND key presses is steam link and the only difference I can see is that it specifically asked for permission to use the controller that it discovered. When using the Pixel 1 and the other apps that worked it did not ask for permission and worked fine.

 

I checked the app permissions, nothing there that I can change that makes a difference. 

 

I went into dev mode and tried each USB default connection setting there was - no change - Steam link recognized it with more than one of the settings.

 

So I am at a loss, does anyone have a USB controller working on the S10e or S10?  Any SN30 USB users out there?

 

thx!

 

Edit: added OS info