Showing results for 
Search instead for 
Did you mean: 

S10e video recordings saved in files with bad or missing moov atom, unreadable by external players



Videos shot on the G970U1 (and I've tried two separate phones) are being saved in incorrectly-built .mp4 files. While playback is still possible on the phone itself, media players on other devices -- across a number of Linux, Windows, and cloud players -- are uniformly unable to play the videos. Player software and ffprobe report that the moov atom is missing from the files.


I believe this bug started with an update at some point in the last 9 months, but I can't confirm that or pinpoint the exact build where things went wrong.


The factory-unlocked phones showing the issue are currently on the AT&T network in the US. They have the baseband version G970U1UES3DTDD , the kernel version 4.14.117-18242889 (May 14), and the June 1 security patch. The software checker reports being up to date.


A Samsung chat rep advised that this is a known issue but that it should have been fixed by some prior update. After I reiterated that the software appears to be current, he pasted a generic boilerplate "wipe the cache partition" message and then marked the issue as "resolved" and left. Needless to say, wiping the cache partition did not resolve the problem.


I also tried installing Open Camera and shooting a video on it, and I got the same failure, even on videos I recorded after manually choosing Open Camera's h.264, HEVC, and 3GPP format options (.webm failed to record off the bat). I suppose that suggests that it's a lower-level problem with the camera driver, but I don't have any real knowledge of how the software stack works for shooting video.


Can anyone else offer any insight into what might be going on here and whether there is a solution or workaround?