JUMP TO SOLUTION Solved

Original topic:

S10e won't send MMS with WiFi on

(Topic created on: 3/30/20 6:35 AM)
user63J5YhnY6s
Asteroid
Options
Galaxy S10

I have an S10e on Xfinity mobile with the stock messaging app, it won't send MMS messages at all anytime WiFi is turned on. Even if mobile data is still on, it won't send. From everything I've read this is a known issue and effects everything from the S8 up since OneUI and Pie were rolled out. If this a carrier issue, a Samsung issue, or what? Everyone is passing the blame and nothing says how to fix it. Please help!

Samsung_8EtT0o1
Astronaut
Options
Galaxy S10

I have the same issue with my S10+. But I think it is because of the T-mobile Wifi-Calling.

0 Likes
Reply
user63J5YhnY6s
Asteroid
Options
Galaxy S10

I don't think it's a carrier setting. I have two S10e's and they both show the same carrier info etc. One works fine, the other doesn't. The only difference is my phone (the one that has no problems) is using Google Messages. My wife's phone, the one that won't send MMS with WiFi on at all, is using the stock Samsung Messages app.

0 Likes
Reply
Solution
user63J5YhnY6s
Asteroid
Options
Galaxy S10

So after multiple attempts and contacting Xfinity, I reset carrier settings for the second or third time and now MMS will send over WiFi. It still takes between 45-75 seconds, but it does go through. Xfinity said if it continues to happen we'll need to change the SIM card.

View solution in context

userbyJWE65rEh
Astronaut
Options
Galaxy S10

Hi there, can you please let me know exactly how you resolved this issue?  I am also with Xfinity and having the same problem.

0 Likes
Reply
userLUsMh0CVfX
Constellation
Options
Galaxy S10

I am having the same problem with my Samsung 10E. I Did everything you said and also changed the SIM card.  It didnt help. Have been going back and forth with comcast for months now and no solution in site.  Sometimes the pictures will send in a couple seconds and other times it'll take anywhere between 30 mins to 2 hours to send one picture. Most of the time it's the longest version.  We also replaced our router twice.  Reset our wifi at least 6 times.  What I want is a new phone.  I have only had this one for 4 months and the problem started 15 days after initial purchase.  UGH!!!!

userwPCo57nybv
Astronaut
Options
Galaxy S10

What did you reset them to.

0 Likes
Reply
useryh67nS94H6
Constellation
Options
Galaxy S10

I had the same issue with my Note 10+. I downloaded the Verizon messaging app and it seems to do much better than the default app

0 Likes
Reply
userr0Abz7D5tl
Constellation
Options
Galaxy S10

I am having problems receiving MMS when I get it through a text message.

0 Likes
Reply
dmck1
Asteroid
Options
Galaxy S10

First - this is NOT an Xfinity problem.  I had (yes, "had" - we'll get to that) the problem and it was an issue on any wifi connection - home (Xfinity), work (Verizon), my brother's house (Cox)...  In addition,  I have a Samsung S9+ and my wife has an S9.  We got them at the same time.  Hers has never had this problem.  We both use Messages from Google LLC instead of Messages from Samsung, although I tried both and had the problem with both.  Oddly, we have different versions of the Google app listed - hers is newer - so I was trying to get that one to load on my phone, with no luck.  However, uninstall and reinstall of the Google Messages application resolved my issue.  I'm not sure what setting I may have missed.  I thought I had checked them all - even the advanced, and I tried the metered suggestion listed here which didn't work for me.  So no smoking gun... just a possible solution for you.

0 Likes
Reply
usergTG5xwWrg0
Astronaut
Options
Galaxy S10

I am experiencing the same problem, as is my father who has an S9 Plus. I tried your solution, but to no avail unfortunately.

0 Likes
Reply