cancel
Showing results for 
Search instead for 
Did you mean: 
user63J5YhnY6s
Asteroid

S10e won't send MMS with WiFi on

JUMP TO SOLUTION

I have an S10e on Xfinity mobile with the stock messaging app, it won't send MMS messages at all anytime WiFi is turned on. Even if mobile data is still on, it won't send. From everything I've read this is a known issue and effects everything from the S8 up since OneUI and Pie were rolled out. If this a carrier issue, a Samsung issue, or what? Everyone is passing the blame and nothing says how to fix it. Please help!

1 SOLUTION

Accepted Solutions
user63J5YhnY6s
Asteroid

Re: I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

So after multiple attempts and contacting Xfinity, I reset carrier settings for the second or third time and now MMS will send over WiFi. It still takes between 45-75 seconds, but it does go through. Xfinity said if it continues to happen we'll need to change the SIM card.

View solution in original post

Reply
Loading...
11 REPLIES 11
Highlighted
Samsung Care Ambassador

Re: S10e won't send MMS with WiFi on

JUMP TO SOLUTION

@user63J5YhnY6s Are you saying you have no LTE coverage and use wifi-calling and MMS did not go through? Did you check your APN settings? is wifi calling fully working? to find out if wifi calling works put your device in airplane mode then turn on Wifi and turn on wifi-calling.




═════════════════════════════════════
If you post new question please specify your Phone model and Carrier.
If you like my comment please hit ♥
if I answer your question please hit the 'accept as solution' button
Reply
Loading...
user63J5YhnY6s
Asteroid

Re: S10e won't send MMS with WiFi on

JUMP TO SOLUTION

No, cellular data and connection are good, full bars. Since I happen to be at my home or somewhere with an Xfinity hotspot, or WiFi I will also be connected to that. Web surfing, email, everything works fine except sending MMS. I have to turn WiFi off entirely in order for any messages to send.

Reply
Loading...
Samsung Care Ambassador

Re: S10e won't send MMS with WiFi on

JUMP TO SOLUTION

Some carriers have issues with Wifi calling. Disable Wifi calling, then try sending some MMS messages with Wifi calling disabled and let us know if that makes a difference.



If you've found my post to be helpful, please like the post. If my response helped resolve your issue, please press the "✓ Accept as Solution" button. Thanks!

Reply
Loading...
user63J5YhnY6s
Asteroid

Re: S10e won't send MMS with WiFi on

JUMP TO SOLUTION

WiFi calling was never enabled on this device, so that isn't the issue. After turning on WiFi calling, that feature works fine

Reply
Loading...
user63J5YhnY6s
Asteroid

Re: S10e won't send MMS with WiFi on

JUMP TO SOLUTION

After messing with different settings it still would not send. Tried sending images, waited about 5 minutes, nothing. Turned WiFi off so it's strictly mobile data, sent immediately. Turned on Roaming Auto Retrieve, sent a picture with WiFi on in just over a minute. Tried sending a GIF, went to 5 minutes without sending.

Reply
Loading...
user63J5YhnY6s
Asteroid

Re: S10e won't send MMS with WiFi on

JUMP TO SOLUTION

We've checked and verified WiFi calling. It was off at first, turned it on and WiFi calling works properly.

Reply
Loading...
Samsung_8EtT0o1
Astronaut

I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

I have the same issue with my S10+. But I think it is because of the T-mobile Wifi-Calling.

Reply
Loading...
user63J5YhnY6s
Asteroid

Re: I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

I don't think it's a carrier setting. I have two S10e's and they both show the same carrier info etc. One works fine, the other doesn't. The only difference is my phone (the one that has no problems) is using Google Messages. My wife's phone, the one that won't send MMS with WiFi on at all, is using the stock Samsung Messages app.

Reply
Loading...
user63J5YhnY6s
Asteroid

Re: I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

So after multiple attempts and contacting Xfinity, I reset carrier settings for the second or third time and now MMS will send over WiFi. It still takes between 45-75 seconds, but it does go through. Xfinity said if it continues to happen we'll need to change the SIM card.

View solution in original post

Reply
Loading...