cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Asteroid

Re: I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

So after multiple attempts and contacting Xfinity, I reset carrier settings for the second or third time and now MMS will send over WiFi. It still takes between 45-75 seconds, but it does go through. Xfinity said if it continues to happen we'll need to change the SIM card.

View solution in original post

Reply
Loading...
Highlighted
Astronaut

Re: I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

Hi there, can you please let me know exactly how you resolved this issue?  I am also with Xfinity and having the same problem.

Reply
Loading...
Highlighted
Constellation

Re: I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

I am having the same problem with my Samsung 10E. I Did everything you said and also changed the SIM card.  It didnt help. Have been going back and forth with comcast for months now and no solution in site.  Sometimes the pictures will send in a couple seconds and other times it'll take anywhere between 30 mins to 2 hours to send one picture. Most of the time it's the longest version.  We also replaced our router twice.  Reset our wifi at least 6 times.  What I want is a new phone.  I have only had this one for 4 months and the problem started 15 days after initial purchase.  UGH!!!!

Reply
Loading...
Highlighted
Astronaut

Re: I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

What did you reset them to.

Reply
Loading...
Highlighted
Constellation

Re: I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

I had the same issue with my Note 10+. I downloaded the Verizon messaging app and it seems to do much better than the default app

Reply
Loading...
Highlighted
Constellation

Re: I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

I am having problems receiving MMS when I get it through a text message.

Reply
Loading...
Highlighted
Asteroid

Re: I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

First - this is NOT an Xfinity problem.  I had (yes, "had" - we'll get to that) the problem and it was an issue on any wifi connection - home (Xfinity), work (Verizon), my brother's house (Cox)...  In addition,  I have a Samsung S9+ and my wife has an S9.  We got them at the same time.  Hers has never had this problem.  We both use Messages from Google LLC instead of Messages from Samsung, although I tried both and had the problem with both.  Oddly, we have different versions of the Google app listed - hers is newer - so I was trying to get that one to load on my phone, with no luck.  However, uninstall and reinstall of the Google Messages application resolved my issue.  I'm not sure what setting I may have missed.  I thought I had checked them all - even the advanced, and I tried the metered suggestion listed here which didn't work for me.  So no smoking gun... just a possible solution for you.

Reply
Loading...
Highlighted
Astronaut

Re: I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

I am experiencing the same problem, as is my father who has an S9 Plus. I tried your solution, but to no avail unfortunately.

Reply
Loading...
Highlighted
Samsung Care Ambassador

Re: I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

@user63J5YhnY6s i dont know if xfinity has this but on stock messaging app can you check the Message Center Number if ever xfinity has it and then check their website if it's the right number? It should start with "+" sign.

Reply
Loading...
Highlighted
Constellation

Re: I have the same issue with my S10+. But I think it is bec...

JUMP TO SOLUTION

Yes. I remember when I switched from my pixel 2 to my galaxy s20+ I noticed that this wasn't in the settings. 

Reply
Loading...