cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Astronaut

Samsung my files not syncing with google drive

JUMP TO SOLUTION

Hello Guys, 

 

Big Samsung fan for several years now, currently using a samsung note 10+ as my daily, and been using DEX for my normal daily tasks like using web apps, emails, excel and word etc. I use ALOT google drive, and I have been trying to configure the sync into the my files manager, without any success. Everything is allowed, it just says ''trying to sync'' but the page is empty. Samsung cloud and Onedrive are working fine. Tried with my Gsuite account and personal account, and they still do not sync. Would really love making this work to ease my workflow when I search for things instead of using the google drive app. 

Tried googleing the issue but I have found no one with this problem. Any of you can help me out ?


I really hope samsung pushes more functions with dex and fix all the annoying bugs, it is really cool being able to do everything from your phoine directly. Apart from running heavy apps on my workstation, the rest can easily be done on DEX and has replaced my laptop for the pass month. 



1 SOLUTION

Accepted Solutions
Highlighted
Asteroid

Re: Samsung my files not syncing with google drive

JUMP TO SOLUTION

Hi Anonymous, 

Thanks for the help, it worked.

 

Although you made a tiny mistake in the process which you given above ( I'm highlighting that mistake by bolding the text and putting it into the "inverted comma") :

 

 

 

1.) (Press as follows) Settings > Apps > My Files > Permissions > Storage > Show all apps with this permission > Menu/Setting icon > Show System > (scroll way the down and you find "Drive" under the denied permissions) > Allow storage permissions. 

 

 

 

Thank you, once again !! Heart

View solution in original post

Reply
Loading...
9 REPLIES 9
Highlighted
Anonymous
Not applicable

Re: Samsung my files not syncing with google drive

JUMP TO SOLUTION

I'm having the same issue, same exact issue. It used to sync when I first got my Galaxy S10. However, I lost my phone and since I've owned the replacement device this has happend to me also. I've tried installing reinstalling both apps, reseting my phone, and going through all the setting to make sure there wasn't something that was making it not sync.

About the only thing I could recommend for you to try is too try some older APK's from about a year ago and try them. If I find one that works I'll come back to this tread and let you know.

Reply
Loading...
Anonymous
Not applicable

Re: Samsung my files not syncing with google drive

JUMP TO SOLUTION

I fixed it! Only took me 3 weeks to figure it out lol. Somehow I believe when the files app updated it didn't automatically ask for the permissions that are necessary for Drive and My Files to sync. So here's what I did and it worked for me. Although the storage permission is allowed in the App section under My Files for some reason is denied in the System Permissions. Here's how you fix it. 

 

    1.) (Press as follows) Settings > Apps > My Files > Permissions > Storage > Show all apps with this permission > Menu/Setting icon > Show System > (scroll way the down and you find My Files under the denied permissions) > Allow storage permissions. 

    2.) (Here's the tricky part that kept getting me. Now exit Settings and go into the My Files App. Your still going to see that Drive still isn't working.) My Files > Google Drive > Menu/Settings Icon > Create Folder. (Then just create any folder you want.) After you create that folder is going to ask for some Google permissions, hit Allow and you should be up and running. I also think it asked me for my Google password and sent me a notification that I had to allow, but that could be just a Google 2-factor Authentication thing. You might not have to do that if you don't have that enabled. 

    Hope this fixes your problem like it did for me. It was driving me crazy 🤪. I even talked to a Samsung, Google, and AT&T Techs and they couldn't give me a solution, and to think they wouldn't hire me when applied for a job as a Technician. Guess they just like to hire the people that say "Just factory reset the device." Me, "I did, it didn't fix it" Them, "Well, ummm. We, do have a promo on the Galaxy S20 right now." ROTF! Well, I hope this works for you "Samsung Warrior."

 

 

Reply
Loading...
Highlighted
Asteroid

Re: Samsung my files not syncing with google drive

JUMP TO SOLUTION

Hi Anonymous, 

Thanks for the help, it worked.

 

Although you made a tiny mistake in the process which you given above ( I'm highlighting that mistake by bolding the text and putting it into the "inverted comma") :

 

 

 

1.) (Press as follows) Settings > Apps > My Files > Permissions > Storage > Show all apps with this permission > Menu/Setting icon > Show System > (scroll way the down and you find "Drive" under the denied permissions) > Allow storage permissions. 

 

 

 

Thank you, once again !! Heart

View solution in original post

Reply
Loading...
Highlighted
Astronaut

Re: Samsung my files not syncing with google drive

JUMP TO SOLUTION

Thanks man. Worked for me too.

I guess I had everything in place, just had to create a new folder and further as you have detailed.

Thanks again.

Reply
Loading...
Highlighted
Constellation

Re: Samsung my files not syncing with google drive

JUMP TO SOLUTION

This worked! Thank you so much.

Reply
Loading...
Highlighted
Constellation

Re: Samsung my files not syncing with google drive

JUMP TO SOLUTION

Thanks, this actually worked.

Reply
Loading...
Highlighted
Astronaut

Re: Samsung my files not syncing with google drive

JUMP TO SOLUTION

Thank you !! Creating a new folder resolved this for me.


@Anonymous wrote:

I fixed it! Only took me 3 weeks to figure it out lol. Somehow I believe when the files app updated it didn't automatically ask for the permissions that are necessary for Drive and My Files to sync. So here's what I did and it worked for me. Although the storage permission is allowed in the App section under My Files for some reason is denied in the System Permissions. Here's how you fix it. 

 

    1.) (Press as follows) Settings > Apps > My Files > Permissions > Storage > Show all apps with this permission > Menu/Setting icon > Show System > (scroll way the down and you find My Files under the denied permissions) > Allow storage permissions. 

    2.) (Here's the tricky part that kept getting me. Now exit Settings and go into the My Files App. Your still going to see that Drive still isn't working.) My Files > Google Drive > Menu/Settings Icon > Create Folder. (Then just create any folder you want.) After you create that folder is going to ask for some Google permissions, hit Allow and you should be up and running. I also think it asked me for my Google password and sent me a notification that I had to allow, but that could be just a Google 2-factor Authentication thing. You might not have to do that if you don't have that enabled. 

    Hope this fixes your problem like it did for me. It was driving me crazy 🤪. I even talked to a Samsung, Google, and AT&T Techs and they couldn't give me a solution, and to think they wouldn't hire me when applied for a job as a Technician. Guess they just like to hire the people that say "Just factory reset the device." Me, "I did, it didn't fix it" Them, "Well, ummm. We, do have a promo on the Galaxy S20 right now." ROTF! Well, I hope this works for you "Samsung Warrior."

 

 


 

Reply
Loading...
Highlighted
Astronaut

Re: Samsung my files not syncing with google drive

JUMP TO SOLUTION

Thanks so much!!! After trying anything imaginable, just this Smiley LOL

You are definitely right about the tech guys Robot LOL

Reply
Loading...
Highlighted
Astronaut

Re: Samsung my files not syncing with google drive

JUMP TO SOLUTION

2.) (Here's the tricky part that kept getting me. Now exit Settings and go into the My Files App. Your still going to see that Drive still isn't working.) My Files > Google Drive > Menu/Settings Icon > Create Folder. (Then just create any folder you want.) After you create that folder is going to ask for some Google permissions, hit Allow and you should be up and running.

 

THIS IS WHAT WAS THE MOST IMPORTANT PART. THANK YOU 

Reply
Loading...