cancel
Showing results for 
Search instead for 
Did you mean: 
McVitas
Cosmic Ray

google calendar not syncing!

JUMP TO SOLUTION

Hello, this makes my life harder a lot! I use calendar on the phone and also on the computer. But I noticed entries made on the phone are not visible online in google calendar online! When I checked phone settings / accounts it is set to be synchronized, but from some reason Calendar last sync date is very old! I did a manual sync and it worked. Like two weeks later I noticed again calendars not being synced. My settings shows the last calendar sync was the manual sync I made and no sync since then happened! I want my calendar to sync so events written on phone appear in google online. And yes, my gmail account is set as default calendar when creating events on the phone.

Screenshot_20191028-165909_Settings.jpg

1 SOLUTION

Accepted Solutions
McVitas
Cosmic Ray

Re: google calendar not syncing!

JUMP TO SOLUTION

So I found the solution and I really wonder why no moderator asked me to check this! Removing and readding account does not make sense if everything else works of course...

CAUSE: I have set my phone into medium power saving mode to try to prolong battery life. It seems that this have caused several problems because it disabled some essential system apps!

I found two problems so far:

Google Photos suddenly stopped uploading my photos into cloud and it worked only when the app was open and always stopped once display timeout happened and phone locked itself!

Calendar stopped syncing

SOLUTION:

nothing easy and intuitive, but finally I found out that I should go to settings / applications / special access / battery optimized apps and switch the list to all. After long browsing I found Calendar Synchronization and also Google Photos. I toggled the checboxes off and voila - photos are now syncing and calendar as well!

And no you can't find them in the obvious place - device care / battery / sleeping apps, so that makes it extra difficult to figure out.

View solution in original post

Reply
Loading...
8 REPLIES 8
Samsung Moderator
Samsung Moderator

Re: google calendar not syncing!

JUMP TO SOLUTION

Have you tried removing your Gmail account and re-adding it?

Reply
Loading...
McVitas
Cosmic Ray

Re: google calendar not syncing!

JUMP TO SOLUTION

no, that did not occur to me. Will try... But it seems like a big "cut" in the system where so many things are tied to my google account ...

Reply
Loading...
McVitas
Cosmic Ray

Re: google calendar not syncing!

JUMP TO SOLUTION

So I found the solution and I really wonder why no moderator asked me to check this! Removing and readding account does not make sense if everything else works of course...

CAUSE: I have set my phone into medium power saving mode to try to prolong battery life. It seems that this have caused several problems because it disabled some essential system apps!

I found two problems so far:

Google Photos suddenly stopped uploading my photos into cloud and it worked only when the app was open and always stopped once display timeout happened and phone locked itself!

Calendar stopped syncing

SOLUTION:

nothing easy and intuitive, but finally I found out that I should go to settings / applications / special access / battery optimized apps and switch the list to all. After long browsing I found Calendar Synchronization and also Google Photos. I toggled the checboxes off and voila - photos are now syncing and calendar as well!

And no you can't find them in the obvious place - device care / battery / sleeping apps, so that makes it extra difficult to figure out.

View solution in original post

Reply
Loading...
McVitas
Cosmic Ray

Re: google calendar not syncing!

JUMP TO SOLUTION

not sure why the picture in my OP was not visible - uploaded it again so hopefully it will stay.

SAMSUNG I have a suggestion for fix in the next update! It seems that none of that settings in accounts / my google account / synchronization makes any sense IF user chooses power savings profile. As you can see those last sync dates are all random which probably means the automatic sync DOES NOT happen unless user opens the respective app! So it would be much better if these settings actually reflect reality - meaning that if user switches to medium or max power savings battery mode these settings would all switch to off state and there can be a popup explaining that this happened. If you go in this settings there would be a message "automatic synchronization is off due to your chosen power saving profile". That would make much more sense and would be true. Looking forward to this fix. Thanks

Reply
Loading...

Re: google calendar not syncing!

JUMP TO SOLUTION

I've been using Android phones for quite a while--phones with stock Android, Oxygen, MIUI, EMUI and various custom ROMs and I don't find the settings in One UI intuitive at all. Some settings don't even seem to be accessible unless you actually do a search for them.

Reply
Loading...
Samsung Care Ambassador

Re: google calendar not syncing!

JUMP TO SOLUTION

No need to fix this "issue." If you choose medium or max power savings mode, the first thing that the system menu says will happen is a restriction on background data. If there's no data being transferred then there's no synchronization



Reply
Loading...
McVitas
Cosmic Ray

Re: google calendar not syncing!

JUMP TO SOLUTION

Please read my post carefuly before replying hastily. I know it was rather long sorry ;-)

All I said was that the menu accounts / my google account / sync should reflect reality! Now what happens is that when you switch to medium or max power savings the synchronization of those thigs is essentialy switched off, but it might seem it is still on because all those toggles remain on! I think that sync settings menu is basically lying in this situation and that's what can be easily fixed IMHO.

Example code: if the calendar sync service is sleeping or stopped then switch the toggle calendar sync off.

Reply
Loading...
Samsung_bWbk84P
Astronaut

Re: google calendar not syncing!

JUMP TO SOLUTION

Very confident, will not let me quit

Reply
Loading...