JUMP TO SOLUTION Solved

Original topic:

Android 11 update, now my screen won't stop waking up when I get a notification

(Topic created on: 1/15/21 3:09 PM)
pandalecoco
Asteroid
Options
Galaxy S20

HELP! SOS!

 

The Android 11 update was just forced on my Samsung Galaxy S20+. 

 

Now everytime I get a text message, my screen wakes up. I want the notification icon to pop up, the sound to go off, but do not want my screen waking up every single time. 

 

Previously the hack fix for this was to turn on Edge Lighting on, but that is not fixing the problem now.

 

I have searched the internet, tried everything I have read (including installing third party apps, which didn't fix it either) , and nothing is working!!!

 

Please help me find a solution to this problem. 

6 Replies
MoniqueO28
Comet
Options
Galaxy S20
Hello. Maybe look under Settings>Notifications>Advanced settings>floatingnotifications and see if you have Smart pop-up view selected. If you do maybe try changing to Bubbles and see if that works. This is just a guess though so idk if this will fix your issue, but I hope it does.

If this does help, could you please click ✓ "Accept as Solution" with the 3 dots next to my comment.- Thanks :smiling_face_with_smiling_eyes:
0 Likes
Reply
pandalecoco
Asteroid
Options
Galaxy S20

Hi, I have floating notifications off. I tried turning them on to see if it helped, it did not. :(

I have to opt out of having notfications shown on my screen to prevent it from waking up. I want to see the notification icon, and hear the sound, just not have the screen wake up. 

pandalecoco
Asteroid
Options
Galaxy S20
The fix to this problem before was turning edge lighting on. Edge lighting is now combined with brief pop up settings.

So the fix I figured out on my own was have brief pop up settings enabled and to show even when the screen is off. And change your messaging app settings to show new message as pop up.

This keeps the screen from waking up with new notifications, but now has a notification bubble associate with it (when screen is on or off), saying "new message". I gave up trying to shut it off, because I don't think it is possible. They need to come out with an easier solution to shut the screen from waking up with notifications.
Members_5kEPi6t
Astronaut
Options
Galaxy S20

issue with this is that now when a person texts and the screen is on it shows a pop-up of what they texted.  why is there the option to not show details in the lock screen but no option to not show details in a pop-up?  I want the edge lighting to turn on when I get a text, not for the screen to wake up, and when the phone is on I also want the edge lighting, but I want it to just say "new message" instead of giving me the details of the message (what if someone is looking over my shoulder at my phone at something i'm showing them and I get a private message i don't want being seen by them??)... but this is now not an option no matter how many settings I tweak.  it's either have the screen wake up, but have privacy when the screen is on.. or have the edge lighting work with the phone off and have a detailed message pop-up when the screen is on......... so annoying!

Solution
MadKata
Constellation
Options
Galaxy S20

I finally managed to do it. Took me some time. I realised that the screen only wakes up on new messages. This is just a "fix" to their big problem. Go to messages, tap those 3 dots and go to settings. Now tap the Notifications. Now, go to New Messages(do bot deactivate it) and on the Lock Screen, select Don't Show Notifications. You will hear the notification when someone messages you via message but when you wake up your screen you won't see any notification from "messages", but others yeah. Sooo, hope this helped you because to me, totally annoyed me.

View solution in context

0 Likes
Reply
user83IqJWwtRv
Constellation
Options
Galaxy S20
I have the same problem. It definitely started with the latest version.
0 Likes
Reply