JUMP TO SOLUTION Solved

Original topic:

Galaxy S20 Ultra 5G will not work with Verizon 5G network

(Topic created: 12-10-2020 05:39 AM)
Anonymous
Not applicable
Options
Galaxy S20

I purchased an unlocked Galaxy S20 Ultra 5g from Samsung with for Verizon but it will not work with Verizon's 5g network! Has anyone else experienced this or found a solution? Verizon told me to contact Samsung and Samsung told me to contact Verizon πŸ™„

1 Solution


Accepted Solutions
Solution
userhoxH2dJzPM
Astronaut
Options
Galaxy S20
Go to Settings>connections>mobile network>network mode. Switch to "LTE/CDMA". The phone will find the network, if you aren't connected to WiFi, you should see the 5G icon in the top right corner, once it finds the network.

View solution in context

9 Replies
Options
Galaxy S20

2 things
one, you may not even have 5g in your area or on your phone.
two, go to Verizon and have them install a free, new SIM. Samsung may not have installed one, or they may have used one from a different carrier.

Anonymous
Not applicable
Options
Galaxy S20

I will try that thanks, and I checked the coverage map and I do have 5g coverage

0 Likes
Reply
useronC2wdLe4a
Constellation
Options
Galaxy S20

Following.. I'm in the same boat- only receiving LTE+, no option to switch to 3G/4G/5G in the connection settings.

 

Not sure if everyone else is experiencing the same. Seems like everyones still waiting on the update from Samsung πŸ€·β€:male_sign:

Options
Galaxy S20

It is my understanding LTE + is the symbol for Verizon's version of 5G UW--at least on non updated UI 2.5 devices.

useronC2wdLe4a
Constellation
Options
Galaxy S20

Im actually really glad you mentioned that @Cheyennehoofhearted . I've been on wifi most the time and it seemed slow when I tested it before going to Verizon and switching my old SIM to the new 5G one. Does seem to be working fast again now, thanksπŸ˜…

Hopefully I'm not imagining it. Hope everyone else's works too πŸ‘

Anonymous
Not applicable
Options
Galaxy S20

I went to Verizon last night and they put a 5g Sim card in my phone and as of right now I still only have LTE + πŸ€·β€:male_sign: anyone else? Will the update solve it?

0 Likes
Reply
FBOL
Galaxy
Options
Galaxy S20
Just got Android 11 update on S20+ 5G and it includes VZW Nationwide 5G!
Anonymous
Not applicable
Options
Galaxy S20
Me too!!!
0 Likes
Reply
Solution
userhoxH2dJzPM
Astronaut
Options
Galaxy S20
Go to Settings>connections>mobile network>network mode. Switch to "LTE/CDMA". The phone will find the network, if you aren't connected to WiFi, you should see the 5G icon in the top right corner, once it finds the network.