JUMP TO SOLUTION Solved

Original topic:

How can I stop incoming calls from interrupting my music?

(Topic created: 08-13-2023 07:38 PM)
Simple-Needs
Asteroid
Options
Galaxy S20

As is incoming calls interrupt my music streaming and playback. 
This is independent of:

  1. Focus Mode
  2. Do not Disturb Mode without exceptions
  3. Calls muted and without vibration
  4. Separate app sound for e.g. Soundcloud or Spotify (Also: Is there a real reason why this feature is limited to 5 Apps?)

Following work-arounds also don't work:

  1. Airplane Mode doesn't work as it apparently does not allow to activate mobile data for some reason.
  2. Under SIM connections I found no possibility to specifically deactivate calls
  3. The call settings provide no possibility to
    1. block all calls irrespective of caller id
    2. call barring; it just states "Failed to read data\nCall barring rejected."

 

In the current state the Samsung Galaxy S20 Plus is effectively unusable as media player. while e.g. jogging as you constantly have to manually reject calls.

I never had such a problem with devices from e.g. Xiaomi

This is a very disapointing experience especially considering the high price of Samsung devices.

Please provide a solution.

14 Replies
Options
Galaxy S20

Hiya, I have a Samsung A34, (I assume your Samsung has the same setting). Would going to the “call barring”  part of the settings and click “all incoming calls” when you want to listen to music and not be bothered by calls? That’s if you don’t mind having to rest every time you finish playing the music on the go.  Just thought I’d say, sorry.

0 Likes
ChaosSaber
Neutron Star
Options
Galaxy S20
I know this isn't what your looking for but I actually use my watch for music and I just turn bluetooth off
0 Likes
Dianna61977
Cosmic Ray
Options
Galaxy S20
If you put it on do not disturb, you still get your notification, and your must does not get disturbed. How is this not an acceptable solution? I do it all the time.
0 Likes
user2JeA3EGQTr
Constellation
Options
Galaxy S20
I am annoyed by this as well, but have not tried to fix it. My music playback is interrupted by any text or other notification. Sounds like more of a notifications problem? Turn those off?
0 Likes
ashleymfdrew
Asteroid
Options
Galaxy S20
I simply mute my ringer and put my whole phone on mute except for media
0 Likes