Original topic:

MMS Won't send over wifi for A23, S20 FE, etc

(Topic created: 09-03-2023 02:15 PM)
Wise95
Constellation
Options
Galaxy S20

I have been trying everything to get my texts to go through with MMS via wifi, but ever since I switched to my first Samsung phone it would not work. I took my SIM card out & out it back in my 5 year old LG, & VOILA, it worked as it always has... MMS went through with wifi, without any problems.

Put the SIM card back into the A23 5G & NOPE! 

I searched EVERYWHERE & found some threads that claimed it is an Android 13 issue. So I opted to buy an older Samsung (refurb) in order to get an older Android system, but lo & behold. the phone retailer had updated the older model with Android 13.

I decided to do some more searching & found out that the issue had actually started with Android 11. I tried NINE different texting apps, did all kinds of things like clearing cache, etc. & NOTHING worked. I had NO IDEA what I was going to do, but I was certain my future was NOT going to be using a Samsung phone until this issue was fixed. I had no clue which other brand phone to buy since our budget is not a big one, & all of the cheaper phones don't last, even when purchased new. I decided I was going to return the replacement Samsung phone (S20 FE) too, but feeling so torn & not having any idea which phone to replace it with, I decided to do a little more reading again.

I found the SOLUTION here in the forums. 

Thank you, Jesus for this comment!! It WORKED!!!!!!!!!! 

I am able to keep the S20 FE because MMS over wifi is WORKING now!!!!!!!! 

 

Such a SIMPLE solution, one would think SAMSUNG would be ALL OVER this with how many ANGRY people there are all over with their phones having this issue. 

 

OPTIONS
Galaxy S Phones
 

Found a solution ....other may want to try with their S 10 . Brief backgound....home has NO cell service ( sits in a mountain valley) For YEARS I had an LG phone with wifi calling through Verizon and it would text ANYTHING instantly through my house wifi and land line.  Recently switched to US Cellular and a new Galaxy S 10.  After setting up everything correctly I tried texting through my wifi line land . Sometimes they went ...in a few minutes , sometimes not for an hour .  Read all these problems online that everyone seems to be having ....changed my messaging app ....even tried the Verizon Message + that worked fine on my old phone and still NOTHING . Finally started digging deeper into my wifi settings on the S 10 .   

 

***** Opened "settings" icon and then clicked on "connections"  opened my home wifi connected which I was connected to under current network. There is a little "gear wheel" to the right of my named connection, pressed it to open another "settings" page for my conection .  On the bottom of this page is an "Advanced" tab. OPEN IT  !  There is a setting called "Metered network"   Mine was originally set ( probably from the factory) as "Treat as metered". Open that tab and set it to "Treat as unmetered"   , Save and exit !!   PROBLEM SOLVED !!  Texts ANYTHING now INSTANTLY !!!   LOVE this phone !  Was going to hate to have to return it because of the texting issue !****

6 Replies
Jameswalter
Cosmic Ray
Options
Galaxy S20

1. Switch to the Apps screen.
2. Tap Settings (you may need to swipe left or right to locate it first).
3. Tap Apps.
4. Select All apps.
5. Scroll down to locate Messages and tap on it.
6. Tap Storage.
7. Tap Clear Data.
8. Restart your device.
9. Try sending a text message. If it doesn't work, perform a factory reset on your device.

0 Likes
Reply
Wise95
Constellation
Options
Galaxy S20

This did not work for my issue. The only thing that did was this:

 

***** Opened "settings" icon and then clicked on "connections"  opened my home wifi connected which I was connected to under current network. There is a little "gear wheel" to the right of my named connection, pressed it to open another "settings" page for my conection .  On the bottom of this page is an "Advanced" tab. OPEN IT  !  There is a setting called "Metered network"   Mine was originally set ( probably from the factory) as "Treat as metered". Open that tab and set it to "Treat as unmetered"   , Save and exit !!   PROBLEM SOLVED !!  Texts ANYTHING now INSTANTLY !!!   LOVE this phone !  Was going to hate to have to return it because of the texting issue !****

0 Likes
Reply
Wise95
Constellation
Options
Galaxy S20

This did NOT work for my issue. The only thing that did was as I stated above:

 

***** Opened "settings" icon and then clicked on "connections"  opened my home wifi connected which I was connected to under current network. There is a little "gear wheel" to the right of my named connection, pressed it to open another "settings" page for my conection .  On the bottom of this page is an "Advanced" tab. OPEN IT  !  There is a setting called "Metered network"   Mine was originally set ( probably from the factory) as "Treat as metered". Open that tab and set it to "Treat as unmetered"   , Save and exit !!   PROBLEM SOLVED !!  Texts ANYTHING now INSTANTLY !!!   LOVE this phone !  Was going to hate to have to return it because of the texting issue !****

0 Likes
Reply
SUEB23
Astronaut
Options
Galaxy S20
Have a galaxy A23 when talking to people it breaks up horribly. Have tried reset and I have internet connection. What else? Anyone else?
0 Likes
Reply
Wise95
Constellation
Options
Galaxy S20

I was told by T-Mobile reps that the A series phones are very basic phones, & not of good quality (they did not say that the quality is lacking directly as they are not allowed to, but I said that & they agreed buying a used S series was a better choice than a new A series). I returned my brand new A23 to buy a used S20FE because the quality of the A was terrible. I am not sure if that is an option for you.

Have you Googled the issue? I read about all sorts of connection issues with Samsung A series phones too. They said that Samsung & T-Mobile pretend like they don't know about the issue. I am not sure where the issue lies, but I can say the S phone performs WAY better than the A phone I had to return & we have T-Mobile.

Is it your phone service? Or the phone? 

0 Likes
Reply
rob578
Constellation
Options
Galaxy S20

Here is an option that works, even with latest update. Go to the play store and download Activity Launcher

Do a search with App (top left) for Mobile Networks . Click and scroll down to MMS messages and turn on.

Your down now you can send and receive mms pictures through WiFi !!! Why this is hidden is beyond me.