Original topic:

My s20+ suddenly not seeing any 5Ghz AC WiFi networks

(Topic created: 05-07-2021 11:36 PM)
usercEL3Zck0UW
Cosmic Ray
Options
Galaxy S20

All was fine till last night but next morning the phone won’t see any 5Ghz WiFi network.

I have tried network settings reset, wipe cache partition, reboot, safe mode. No luck.

Nothing has changed on the phone or my travel router side. 
my old s9 and my Apple iPad can see the network without any issue.

I can’t even use any 3rd party app on the s20 for search for 5Ghz wifi. It looks like the radio on the phone is not even ON.

however i can turn on the hotspot of the phone and choose to use the 5Ghz radio for the hotspot. So that tells me that the 5Ghz radio is fine?

im currently traveling internationally so factory reset is not an option and frankly shouldn’t be needed for this.

0 Likes
2 Replies
usercEL3Zck0UW
Cosmic Ray
Options
Galaxy S20

Soan update.

I came acros another thread here and the based on what I read there I tried manually setting the channel to 161 on my router for the 5Ghz band and behold the WiFi then showed up on my phone again.

I don’t know what to make of all this. There is definitely going on in the phone  and from of the looks of it, as is always the case here, Samsung is not providing any useful feedback on this here.

 

0 Likes
usercEL3Zck0UW
Cosmic Ray
Options
Galaxy S20

OK I think I may have solved the mystery. As I had said that I’m traveling internationally. I am currently using a Sim card from the country that I am in at the moment. I looked up and there are only five channels that are allowed in this country. So I think when I inserted the local Sim card into my phone and even though my phone is from the US plus it’s an unlocked model and my router is also from US. However I believe that once I put the sim in the phone, it disables the non authorized bands for the region for that SIM card.

however it doesn’t explain why my phone had been working fine for the last week without any issues though…perhaps the router by chance was already AUTO using the channel that were being seen by the phone. I did reboot the router several time in the last two days so perhaps it ended up using a channel that eventually because incompatible with the phone.

0 Likes