cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Asteroid

PSA - Delayed/No Notifications on Android 10? Turn Off Adaptive Notifications!

Greetings and good day to you, hope you're staying safe Smiley Happy

 

Straight to the point, if you're having issues with your notifications arriving late or even not arriving at all on Android Q (10) the issue appears to be the new default "Adaptive Notifications" that Google introduced and made it the new default option, strangely.

 

It is essentially a way for Google to automatically manage your notifications, using AI. And that is what messing up the notifications and how they work.

Turning this off basically let the notifications work as before, in normal behavior, no delays, no priority, no nothing. The way it should be.

 

To turn it off, basically go to :

Settings -> Apps -> 3 Dots Menu -> Special Access -> Adaptive Notifications -> Set it to None

Or you can just search "Adaptive Notifications" in your settings' main screen and you'll jump there.

 

(on Samsung phones, it's known that any Power Mode other than High Performance will cause some delays to save battery, so keep that in mind)

 

Restart your phone after doing this, then check on it again to make sure it's set to None.

 

You should receive your notifications instantly now, I was having issues with Google Reminders and Gmail and several other apps' notifications but it appears that this AI stuff is what causing it.

 

Good luck and hopefully it'll work out for you just like it did to me Smiley Happy

1 REPLY 1
Highlighted
Constellation

Re: PSA - Delayed/No Notifications on Android 10? Turn Off Adaptive Notifications!

OMG. Finally!!!! Thanks alot bro. It resolved the issue I was facing for last 10 days after updating to Android 10. Thanks alot for sharing it. Appreciate it! 👍

Reply
Loading...