JUMP TO SOLUTION Solved

Original topic:

S20 FE Google Assistant voice wakeup doesn't work when phone untouched for a while

(Topic created: 09-27-2021 12:22 AM)
userXAqaKSI3J1
Asteroid
Options
Galaxy S20

Hey, 

I have S20 FE for a month or so and ever since the purchase, the phone wakes up to "hey google" only if I recently did something on it for a while. If I don't touch it for some minutes and try to talk to it, it ignores me. Sometimes just turning off the screen is enough for it to stop listening.

I made sure Google is not battery optimized but didn't change a thing.

SOLUTION:

Just to make sure everyone knows how I fixed this. I did what  pointed out:

- I made sure the app cannot go into deep sleep. If it were there you'd find it here: Device settings>device care>battery>app power management>sleeping apps. You can also set there close by, that you do not want ever to go it to sleep.
- I made sure that it is not battery optimized "settings>apps>3 dots>special access>optimize battery usage> near the top change "apps not optimized" to "all">Google and assistant>turn off optimization"

1 Solution


Accepted Solutions
Solution
Je655
Red Giant
Options
Galaxy S20
I thought you were talking about "optimize battery usage" in your post
settings>apps>3 dots>special access>optimize battery usage> near the top change "apps not optimized" to "all">Google and assistant>turn off optimization

So you don't see assistant in this menu & you turned off battery optimization for Google?

View solution in context

6 Replies
Je655
Red Giant
Options
Galaxy S20
Device settings>device care>battery>app power management>sleeping apps.
Did it get added to sleeping apps?
userXAqaKSI3J1
Asteroid
Options
Galaxy S20

No. I made sure Google app is exception and I didn't see a dedicated assistant app in any of those lists. Also, I did point that out in the original post.

Solution
Je655
Red Giant
Options
Galaxy S20
I thought you were talking about "optimize battery usage" in your post
settings>apps>3 dots>special access>optimize battery usage> near the top change "apps not optimized" to "all">Google and assistant>turn off optimization

So you don't see assistant in this menu & you turned off battery optimization for Google?

View solution in context

userXAqaKSI3J1
Asteroid
Options
Galaxy S20

Oh my, those are two separate things? Jeez! Thanks for spotting that. Well, indeed I found Google Assistant in this other setting to be optimized. Multiple entries for that. Turned off all of them, let's see how it goes, I'll test it for a day or two.

I find it mind-boggling, why these aren't stock settings. How many users will realize that Samsung isn't smart enough to turn off disruptive optimizations for core functionality like the assistant? 😕

Je655
Red Giant
Options
Galaxy S20
0 Likes
Reply
iamblue
Supernova
Options
Galaxy S20

retrain the voice?

0 Likes
Reply