JUMP TO SOLUTION Solved

Original topic:

S20 UI 3 WiFi not automatically turning off

(Topic created on: 1/3/21 1:23 PM)
WuzUpG
Asteroid
Options
Galaxy S20

Model Number: SM-G981U1

One UI version: 3.0

Android version: 11

Current version: G981U1UEU1CTKJ/G981U1OYM1CTKJ/G981U1UEU1CTKJ

Security Patch level: December 1, 2020

 

After updating to the UI 3, I noticed my WiFi not automatically turning off, using Intelligent WiFi.  I tried using Bixby Routines to automatically shut off WiFi, when I leave.  When I left, Bixby Routines turned on Bluetooth, which I had set, but it didn't shut off WiFi.

 

I reached out to @SamsungSupport on Twitter and they suggested to reset the network settings, which I did.  The problem still exists.

 

Today, I manually shut off WiFi, while I was away.  When I arrived, Bixby Routines turned on the WiFi (and turned off Bluetooth), which is what I had set.

 

So it appears that my device is recognizing the address, when leaving and arriving, for Bixby Routines.

 

@SamsungSupport wanted me to restart my phone in Safe Mode, to see how it reacts, but I'd lose all my customizations and themes, which isn't worth the effort for turning off WiFi.

 

Other weird occurences, after upgrading to UI 3, it disabled some apps and changed my storage settings from External back to Internal.  Also, when I turn on my Hot Spot, it sometimes (not consistent) automatically shuts off my Mobile Data.

0 Likes
Reply

1 Solution


Accepted Solutions
Solution
WuzUpG
Asteroid
Options
Galaxy S20

I just had a software update and Intelligent WiFi turned off automatically.

 

I'm not certain why mobile networks/data keeps shutting off automatically, when I start/stop Hotspot, WiFi, and/or Bluetooth (no consistency)

View solution in context

0 Likes
Reply
5 Replies
DGM
Sun
Options
Galaxy S20

Btw, you might also try to do a reset:  Retset all settings (rather than Network).... might help you.

 

 

You might also try this to see if it helps,  that is if you have bluetooth in your car.  If so, make the "triggering event bluetooth turning on in your car" - - then select all other options you want, ie, turn-off wifi....     Hopefully this works for you.

 

 

Be sure to click  " ✓ Accept as Solution"  when you find an answer that works for you.  -  Thanks!

0 Likes
Reply
WuzUpG
Asteroid
Options
Galaxy S20

I do have the trigger when leaving an address to:

1) Turn on Bluetooth

2) Turn off WiFi

 

When routine ends, reverse the actions.

 

When I left, Bluetooth turned on, but WiFi was still on.  I manually had to turn WiFi off.

When I arrived, Bluetooth turned off and WiFi turned on.

0 Likes
Reply
DGM
Sun
Options
Galaxy S20
Hmmm... have you removed the routine and put a fresh one in? or maybe even try to separate into two separate routines... leaving home and returning home. I realize that should not make a difference, but who knows? Good luck.
0 Likes
Reply
userxxhWg9k8E3
Cosmic Ray
Options
Galaxy S20
Safe mode won't delete your customizations. they won't be there in safe mode, but they will return after you restart normally.
0 Likes
Reply
Solution
WuzUpG
Asteroid
Options
Galaxy S20

I just had a software update and Intelligent WiFi turned off automatically.

 

I'm not certain why mobile networks/data keeps shutting off automatically, when I start/stop Hotspot, WiFi, and/or Bluetooth (no consistency)

View solution in context

0 Likes
Reply